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1 ABOUT THIS GUIDE

1.1

1.2

1.3

1.4

1.5

Green light's AVM-RTA Design Studio (RTA DS) is a software application that
extends the SAP GRC applications for Access Control (AC) and Process Control
(PC) to non-SAP systems in the customer’s IT landscape. The AVM RTA DS
application establishes connections to non-SAP ERP systems and provides data to
AC or PC. AVM-RTA DS has many valuable features including the ability to
establish real time connections to target ERP systems, databases, legacy systems, as
well as reading data from flat files.

This guide is to familiarize users with the AVM RTA DS application.

DOCUMENT PURPOSE

This document is intended as a starting point for understanding the overall
capability of the AVM RTA DS application.

DOCUMENT CONVENTIONS

Document conventions are as follows:
1. Bold Book Antiqua to designate names of icons, buttons and menus and
emphasize important terms.

2. Italic Book Antiqua text in blue to designate hyperlinks and cross-references.

RELATED DOCUMENTS

AVM RTA DS Installation Guide v2.0SP07 -This document contains step-by-
step instructions on the installation of the AVM-RTA Design Studio.

TARGET AUDIENCE

This manual is intended for System Administrators, Solution Administrators
and/or Technical People, who are responsible for using the AVM- RTA DS
product for Risk Analysis through SAP RAR or configuring various real time
adapters for different applications.

MASTER STARTING POINT

The AVM RTA DS is an application that extends the SAP GRC capabilities for
Risk Analysis to the non-SAP systems. This is accomplished by installing the
AVM RTA DS and the appropriate target ERP system connector. After installing
AVM RTA DS and the RTA, use the RTA DS to configure the connector
parameters and settings. This enables the communication between the SAP GRC
product and the Target ERP RTA to pull data from the ERP system and reformat
it for consumption in GRC.
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1.6

To begin with, the first step is to install the software. The software consists of two
main components as follows.

1. Greenlight AVM-RTA DS
2. RTA Adapter
The documents required are as follows:
1. AVM-RTA DS Installation Guide
2. AVM-RTA DS User Guide
3. Real Time Adapter Installation Guide

To install the first software component, follow the instructions given in the RTA
Design Studio Installation Guide. Once the AVM-RTA DS is installed and
verified, install the Target ERP system RTA as per the instructions in the Real
Time Adapter Installation Guide for Adapter.

The next step is to configure the AVM-RTA DS. This involves setting up the SAP
GRC RAR product to access the AVM-RTA DS and configuring the AVM-RTA
DS to access the RTA in Oracle. After configuring SAP GRC, the AVM-RTA DS
and the RTA, test the connection and validate if the systems are working
together. Once the systems are validated, you can extract users, roles, and
permissions for analysis in the SAP GRC RAR Product.

SECURITY

The AVM RTA DS is an application that relies on the SAP GRC product for
handling the User management activities. The AVM-RTA DS software package
and its configuration data do not provide any user accounts or passwords.

However, certain Id’s are required for the proper functioning of the system.
These ID’s are established in the SAP GRC UME as follows:

1. Administrator - is capable of defining the connector, applications, systems
and registration in the RTA Design Studio.

2. System Owner - owns the system that is connected to RTA Design Studio.
The system owner can import, export system adapter metadata and has
access to standard adapters under adapter metadata, Auto Batch Execution.

3. System User - is the end user of any specific system connector - Access to
just the informer and Auto batch Execution.

The System Admin role has sufficient privileges to configure and maintain the
system and connections. For more information on this, refer RTA Design Studio
Installation guide. To manage the user accounts and privileges refer to: the SAP
GRC documents.

1.6.1 COMMUNICATION

The AVM RTA DS is typically installed on the same NetWeaver server where
GRC Access Control/ Compliance Calibrator is installed. In case of Oracle
Applications it is a standard JDBC communication.
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1.7 CONTACT GREENLIGHT

For any questions or queries contact:

Email: support@gqreenlightcorp.com

Web: www.greenli¢htcorp.com
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2 OVERVIEW

AVM RTA DS is a web-based tool to configure web services and adapters to
connect to multitude of systems. For compliance purpose, the AVM RTA DS
v2.0SP07 deals with connecting to the systems through SAP’s Risk Analysis and
Remediation (alternately known as Compliance Calibrator) Product.

2.1 INTRODUCTION

The requirements of the AVM RTA DS are as follows:

1.

The AVM RTA DS manages configuring web services and adapters. It
removes redundancy and improves reusability of the web services and
adapters to connect with various standard and legacy systems.

It incarnates the Object Oriented approach to configure web services leaving
significant components of the Adapters to be reused in different web service
configurations.

It also encapsulates the complexity involved in deploying the web services
for various systems.

The systems configured for web services through AVM RTA Design Studio
can be centrally managed and enhanced as required. It provides the
framework to generate various reports from whatever system that is
connected through AVM RTA DS.

The AVMRTA DS has Role based access. So securing its access to various
profiles across the hierarchy of the organization.

Key features of AVM RTA DS are as follows.

1.

The AVM RTA DS provides ease of configuring Real Time and Batch Extract
adapters to feed data to SAP ARA.

It provides reusability of programs to configure adapters.
It provides various default reports as well as customized reports.

Debugging of the web services connection in AVM RTA DS is easier. The
point of error can be easily diagnosed.

The various components in AVM RTA DS have role-based access. The
person delegated to the task of specific component maintenance and
updating can only access these components.

6. Using the Upload SOD Rules Configuration feature, you can configure

GRC Application Connector for the Upload SOD Rules functionality.

Note: if you are not using Upload SOD or Offline feature this configuration
is not required.
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2.2 ARCHITECTURE
The following section illustrates how AVM RTA DS is deployed on SAP NWA.
2.21 AVMRTA DS DEPLOYMENT ON SAP NW AS 7.31+

1. AVM RTA DS can be deployed in the following two ways for GRC 10.x
integration depending upon if GRC is deployed on a dual stack Netweaver
system (ABAP + JAVA) or just ABAP system.

2. Even if the dual stack is available for the GRC box, application can be
deployed on a separate Netweaver Java Stack.

3. AVM-RTA DS utilizes the Net weaver Java Stack Database onto which it is
deployed to create and populate its tables.

SAP GRC 10.x Greenlight AVM (RTADS)

Databases

JDBC /APIs ‘Oracle
Teradata,Cassandra,
Mongo DB , Green Plum

etc.
WS

RPG

—_— Applications
HTTP (S)
FTP (5) Applications like
SPHML NER BSFN c -
UeerProvisioning ! L, i Concur, Su:tt‘::ess Factors
Execution Engine BSSV i
Centralized Logging, L, a—
' Monitoring, iCo Homegrown, Legacy
Trobleshooting, T
—— - System of Record —
‘RiskManagement ‘ Reports | S
SOAP/ x
Odata/ COTS - 150+ applications

SAP Net Weaver AS ABAP SAP Net Weaver e

AS Java7.31+ LDAP

Figure 2.1: Landscape Architecture

Note: If AVM is installed on a clustered NW JAVA instance (multiple
application servers / multiple JAVA server nodes) then please
maintain either Message Server based application URL or URL based
on any load balancer (if one has been deployed in customer
landscape) to distribute requests from Access Control to AVM.
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3 LOGIN DETAILS

The User Login for the AVM RTA DS happens through SAP User Management
Engine (UME). In UME, various AVM RTA DS role components are imported
through text file. The roles for a user can be configured through SAP UME. It
allows access to various Links, Tabs and Buttons as per the user profile.

3.1 USER LOGIN

All the active users defined in UME can login to the application through User
Logins. To have an appropriate access within the application, ensure that a role
with one or more actions is assigned to the users.

On the User Login Screen, the Registration (for registering the platform) and the
Support links are provided for the product. Platform should be registered first
for user to login to the AVM RTA DS Application.

3.1.1 REGISTERING PLATFORM

The steps to register the platform are as follows.
1. Launch the AVM RTA DS application.
2. Click the Registration link.
3.  Enter the User ID and Password of system administrator.
4.  Click on the Register the Platform.

ALUESS WIDLANION MAHAGEMEN |

Welcome
User Login
SMTP Settings

Registration

Support

User ID* |

Password*

Language English

| Register the platiom |

Figure 3.1: Platform Registration
5. The Platform Registration screen opens.
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ATEGESS VIOLANDN MANAGEMER]

User Login

SMTP Setfings.
Registration

Support

Help | About

I Platform Registration

Execute Install Scriot

Registration : NOT REGISTERED

| Customer Id:

6.
7.

| Customer Name=*
| Contact Name:*

| Address*

| state Coder”

| Zip Code™

| Email Address*

Figure 3.2: Platform Registration
Click on the Execute Install Script button.
The Details screen opens.

S o] cove

File Browse. ..

Details JE3}

Figure 3.3: Details
Click on Browse button and select appropriate install script.

Note: This script is provided in the build/package folder. The
database scripts should not be having than one semi colons
in a query. Single Query should be written on single line.

Click on the Execute Install Script button. The screen displays message
as shown in the below screenshot. Detail information about the executed
script is displayed under the Script Execution Summary section under
the column headings Table Name, Operation and No. Of Executed
Queries.

Install script executed successfully.

e

‘Script Execution Summary:

GLT_XPA_SETTINGS INSERT 3

GLT_XPA_SEQUENCES | INSERT 55

Details (6]

Figure 3.4: Details

10. Click on the Cancel/Close (image in the right corner) button and go to

the Platform Registration screen.

11. Enter appropriate Customer Id, Customer Name, Contact Name, and

Address (of customer), State Code, Zip Code and Email Address (of
customer).
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Platform Registration

Save Execute Install Script

| Customer 1d:* GLT

| Customer Name:* Greenlight Technologies
| Contact Name:* Wike Kelly

| Address= Park Avenue

| state Code* MH

| Zip Cote 411038

| Email Address= admin@greeniightorp.com

Registration : NOT REGISTERED

Figure 3.5: Platform Registration

12. Click on Save. The screen displays message as shown
screenshot.

in the below

Platform Registration

Registration partially completed, Please upload the license key.

Execute Install Seript

| Customer 1g:* GLT

| Customer Name:* Greenlight Technologies

| Contact Name:* Mike Kelly

| Address:* Park Avenue

| State Code:™ MH

| Zip Code* 411038

| Email Address= admin@greenlightorp.com

| License Key:* Browse...

Registration : IN-PROCESS

Figure 3.6: Platform Registration

13. All the modifications are grayed out and the License Key field appears

on the screen.

14. Click on the Browse button and import the GLT_RTADS_PLAT.xml

file provided with the build.

F Platform Registration
[Registration partially completed, Please upload the license key.

Execute Install Script

| Customer Id:* GLT

| Customer Name:* Greenlight Technologies

| Contact Name:* Mike Kelly

| Address* Park Avenue

| State Code:* MH

| Zip Code* 411038

| Email Address:* admin@greenlightorp.com

| License Key:* :skiop\GLT_RTADS_PLAT.XML| Browse...

Registration : IN-PROCESS

Figure 3.7: Platform Registration

15. Click on Save. The screen displays message as shown
screenshot.

in the below

Greenlight Technologies, Inc.
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|i Platform Registration
R

Key saved y.

|

| Customer Id: GLT

| Customer Name:* Greenlight Technologies

| Contact Name:* Mike Kelly

| Acdress™ Park Avenue

| State Code:* MH

| Zip Code:* 411038

| Email Address:* admin@greenlightorp.com

Registration : REGISTERED|

Figure 3.8: Platform Registration

3.1.2 LOGIN

The steps to login to the AVM RTA DS application are as follows.
1. Launch the AVM RTA DS application.
2. In the left pane, click on the User Login link.

The login screen appears as shown in the following screenshot.

ACCEZS VIOLAINDN MAHAGEMERN |

Welcome
User Login

SMTP Settings

Registration

Support
User ID# sapuser
Password™ sssanal
Language English

Logon

Figure 3.9: User Login

3. Enter appropriate User ID and Password in the respective fields.

4. Click Logon to login to the application.
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4 CONNECTORS

Using the Connectors feature, you can create connectors. For each system, you need
to create at least one connector. Using the Connectors page, you can search, create,
view, modify and test the connection.

41 SEARCH CONNECTORS

Use a search criterion to find the previously created connectors. The search
criterion helps you to search a particular connector or find all the existing
connectors in one go.
The steps to search the connectors are as follows.
1. Click on Configuration tab.
2. In the left menu pane, click on the Connectors link.

The Connectors>Search screen opens as shown in the following screenshot.

EER———
% || Connectors > search
+ Registration
Create || Delete || Open Test Gonnection Enable Signature Audit Logs Disable Signature Audit Logs
» Application Center
» Utilies In
» Logs Monitor ame
+ Application Log | Description
| connection Type FLATFILE_TEXT [
o
Select 1d Name T Deseription Connection Type
2004 | FLATFILE_GONN Natfile_conn FLATFILE_TEXT
(4]« Page 101 oo

Figure 4.1: Connectors>Search
3. To view all the existing connectors, click Go.
-Or-
To view a particular connector, enter the parameter value in the
Name/Description field. Select the Connection Type from the dropdown
list. Click on Go.
4. The screen displays records under the column headings Select, Id, Name,
Description and Connection Type.
5. To sort the data in ascending/descending order, click the arrow beside the
Name column.
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4.2 CREATE CONNECTORS

You need to create two WEBSERVICE connectors.

a.

b.

GNP

10.

11.

One webservice connector is to get role details (start date, end date) from
the SAP GRC for the submitted request. Example: RQST_DTLS_CONN

The other is user access webservice connector which will remove the roles
from SAP GRC request (in GRC table) so that same role can be submitted in
next request. Example: USRACCES_WS_CONN

The steps to create the Role Details Webservice Connector are as follows.
Click on the Configuration tab.

In the left menu bar, click on the Connectors link.

The Connectors>Search screen opens.

Click on Create.

The Connector>Create page opens.

Informer Adapter Manager Configuration

x I Connectors > Create

» Registration

save [|_Cancs
» Application Center
b Utilities | Name =
F Logs Monitor
| Description =
| Connection Type* [~select- ~]
| status® [Active ~]

Figure 4.2: Connectors > Create
In the Name field, enter appropriate name of the connector. For Example:
RQST_DTLS_CONN.
In the Description field, enter brief description of the connector.

In the Connection Type drop-down list, select the connector type as
WEBSERVICE. After selecting the connection type, some additional fields
appear on the screen.

In the Status dropdown list, select the status as Active.

In the URI text box, enter the appropriate URI obtained from GRC.

For Example:

http:/ /linux-
jonll.greenlight.com:8000/sap/bc/srt/rfc/sap/grac_request_details_ws/10
0/glt_grac_request_details_ws/glt_grac_request_details_ws

For more information on how to get URI, refer
GRC_CG_for_10.0_10.1_v1.5.pdf- section 4.2 Request Details webservice
Binding.
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12. In the User Name and Password text box, enter appropriate credentials in the

respective text box.

13. In the Web Service Name text box, enter the value as REQUESTDETAILS.
14. Click on the Save button to save the newly created connector settings.

15. The screen displays message as “<Connector Name>: Connector created

successfully”.

Informer Adapter Manager

Configuration

x I Connectors = Open

= Registration

save ||| _cancel
¥ Application Center
» Utilities | id

¥ Logs Monitor
| Name =

| Description -*

2002

RQST_DTLS_CONN

RQST_DTLS_CONN

| Connection Type* |WEBSERVICE v
| Status® [Active ]
| umi= 2quest_details_ws/glt_grac_request_details_ws
| UsermMame sapuser
| Password :* csssssss

| | Web Service Name = REQUESTDETAILS

Figure 4.3: Connectors > Open

B. The steps to create the User Access Webservice Connector are as follows.

Click on the Configuration tab.

The Connectors>Search screen opens.
Click on Create.

The Connector>Create page opens.

SN

In the left menu bar, click on the Connectors link.

Greenlight Technologies, Inc.
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10.
11.
12.

13.

14.

15.
16.
17.

Informer Adapter Manager Configuration
x I Connectors = Create
» Registration
Save |||_Cance

» Application Center

b Utilities | Name =

» Logs Monitor
| Description =
| Connection Type* [select- ~]
| status® [Active ~]

Figure 4.4: Connectors > Create
In the Name field, enter appropriate name of the connector. For Example:
USRACCES_WS_CONN.
In the Description field, enter brief description of the connector. For
Example: User Access Webservice Connector.

In the Connection Type drop-down list, select the connector type as
WEBSERVICE. After selecting the connection type, some additional fields
appear on the screen.

In the Status dropdown list, select the status as Active.

In the URI text box, enter appropriate URI obtained from GRC.

For Example:

http:/ /linux-
jonll.greenlight.com:8000/sap/bc/srt/rfc/sap/grac_user_acces_ws/100/ glt
_grac_user_acces_ws/ glt_grac_user_acces_ws

For more information on how to get URI, refer:
GRC_CG_for_10.0_10.1_v1.5.pdf- chapter 4.1 User access webservice request
binding.

In the User Name and Password text box, enter appropriate credentials in the
respective text box.

In the Web Service Name text box, enter the value as USERACCESS.

Click on the Save button to save the newly created connector settings.

The screen displays message as “<Connector Name>: Connector created
successfully”.
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x I Connectors > Open
= Registration
b Application Center
Utilities

» | = 2001

} Logs Monitor
| Mame = USRACCES_WS_CONN
| Description == USRACCES_'WS_CONN
| Connection Type* [WEsSERVICE
| status® [Active
| uri _grac_user_acces_ws/glt_grac_user_acces_ws
| User Name = sapuser
| Password [ —

| | web Service Name :* USERACCESS

Figure 4.5: Connectors > Open

4.3 VIEW/MODIFY CONNECTOR

The steps to view/modify the connector are as follows.

1. On the Connector > Search page, select the connector whose details you
wants to modify/view.

2. Click on the Open button.

The Connector > Open screen opens displaying the information of the
selected connector in various fields.

I Connectors > Open |

| a= 2012

| name = JDBC_CONN

| Description =* JDBC_CONMN

| Cconnection Type [JpBC v
| status* |Ar:1|\te "l

I Driver Name com.microsoft sglserver jdbc. SQLServerDriver

| uRL: jbdc:sglserver192.1688.1.23:databaseName

| Userip sa

| Password: sensas

Figure 4.6: Connector>Open
3. The Id and Name fields are not editable.
4. Edit the Description if required.
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5. Edit the Connection Type from the Connection Type drop-down list.
6. Modify the required fields based on the connection type.
7. Click on the Save button.

The screen displays the message as shown in the following screenshot.

Message from webpage

\:{/ Updating the connector may Fail the jobs that might be running For this connector, Do you still want ko update the connector? Click OK ko Proceed or Cancel to Abort

[ Ok ][ Cancel ]

Figure 4.7: Message
8. Click OK to continue or Cancel to Abort.

4.4 DELETE CONNECTOR

You can delete a connector by two ways:
1. Selecting a connector and making its status Inactive.

2. Selecting a connector and click on Delete button.
4.4.1 DELETING A CONNECTOR BY CHANGING ITS STATUS

The steps to delete a connector by changing its status are as follows.
1. Click the Configuration tab.
In the left navigation pane, click on Connectors link.

3. On the Connector>Search page, click the select column corresponding to
the Name which you want to delete.

4. Click on the Open button.

The Connector>Open page opens displaying the details of selected
connector in each field.

5. In the Status dropdown list, select the status as Inactive as shown in the
following screenshot.

I Connectors = Open
M Cancel
(RS 2012
| Name * JDBC_CONN
| Description * JDBC_COMNN
| Connection Type* JDBC ~
| stats* v
| Driver Name : com.microsoft.sglsenver jdbc.SQLServerDriver
| URL: jbdcsglserverdi192.168.1.23:databaseName
| useriD: sa
| Password: ssasee

Figure 4.8: Connector>Open
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6. Click on the Save button. The screen displays message as shown in the
following screenshot.

Message from webpage

‘“‘?I‘J Yaou are about to delete connector JDBC_CONMN, Do you wank to conkinue?

[ oK, H Cancel ]

Figure 4.9: Message
7. Click on OK to delete the record.
The screen displays message as, "<Connector Name>: Connector deleted
successfully."

Note: once you select the status as Inactive, you cannot change it to Active.
If you try to change the status of the connector, which is associated
with system, the screen alerts with RED error message as shown in the
following screenshot. Once the new Connector is saved it is available
to map under Configuration> Application Center>System-Create

R

x I Connectors > Open

= Registration ‘Cannot mark 8NJ connector as In-Active.
= Connectors ‘Connector is mapped with following Systems

Application Center SNFM1
¥ Utiliies
» Logs Monitor Save Cancel

» Application Log
lia= 2025

| Name = 8Ny

| Description == aNJ

| Connection Type JDBC &
| status Active L
| Driver Name aracle jdbc.OracleDriver

| URL jdbcoraclethin:@192.168.1.25:1527:GL4

| userip SAPSR3DB

| Password: [ eeessess

Figure 4.10: RED Error Message
4.4.2 DELETING SYSTEMS USING DELETE BUTTON

The steps to delete a connector by clicking delete button are as follows.
1. Click the Configuration tab.
In the left navigation pane, click on Connectors link.

3. On the Connector>Search page, click the select column corresponding to
the Name which you want to delete.

4. Click on the Delete button.

The following message appears on the screen.
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Message from webpage x|

\_?r/ ‘ou are about to delete connector . Do vou want to continue?

(] 4 I Cancel |

Figure 4.11: Message
5. Click on the OK button.

The screen displays message as, "<Connector Name>: Connector deleted
successfully" as shown in the following screenshot.

Note: you cannot delete a connector mapped with the system.

I Connectors > Search
JDE : Connector deleted successfully.
Create | Delete | Open | Test Connection Enable Signature Audit Logs Disable Signature Audit Logs
| Name:
|Descript\un.
| Connection Type _Select— ;I
o]
Select |d Name + Description Connection Type
2008 ERP ERP JDBC
(o 2004 FLATFILE_CONMN flatfile_conn FLATFILE_TEXT

Figure 4.12: Connector > Search
4.5 TEST CONNECTION

The steps to test the connector are as follows.

1. Got to the Connectors > Search screen.

2. Select appropriate connector, which you want to test.
3. Click on the Test Connection button.

The application displays the message as, <Connector Name> Success as
shown in the following screenshot.

I Connectors > Search
FLATFILE_COHNN : SUCCESS
Create ‘ Delete ‘ Open ‘ Test Connection Enable Signature Audit Logs: Disable Signature Audit Logs
| Mame:
|Descnpliun
| connection Type —Select— ;l
o]
Select 1d Name # Description Connection Type
e} 2008 ERP ERP JDBC
(ol 2004 FLATFILE_CONN flatfile_conn FLATFILE_TEXT

Figure 4.13: Connector>Search-Test Connection
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5 APPLICATION CENTER

The Application is a homogeneous group of the Systems. For Example: PeopleSoft
is an Application and PeopleSoft HR Dev, PeopleSoft HR Prod are its systems.

5.1 APPLICATION

Using application screen you can create/search and modify the previously
created applications.

511 SEARCH APPLICATIONS

A search criterion helps to find the previously created applications. The
search criterion helps to search a particular application or find all the existing
applications in one go.

The steps to search an application are as follows.

1. Click the Configuration tab.

2. In the left navigation menu, click the Applications Center.
3. Click on the Applications link.

The Applications>Search page opens as shown in the following
screenshot.

e i

X I Applications > Search

= Registration

= Connectors Create Open

w Application Center

Applications

= Systems |D95criptinn'

I MName:

» Utilities Go
w Logs Monitor
« Application Log Select Name 7 Description
¢ |FRI_APP FRI_APP
(o GLT_APP GLT_AFPP

Figure 5.1: Application>Search
4. To view the existing applications records, click Go.
-Or-

To view a particular application, enter the parameter value in the
Name/Description field and click on Go.

5. The screen displays records under the column headings Select, Name,
and Description.

5.1.2 CREATE APPLICATION

The steps to create a new application are as follows.
1. Click the Configuration tab.
2. In the left navigation pane, click Applications Center>Applications.
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3. The Application>Search screen opens.
4. Click on the Create button.
The Application>Create page opens as shown in the screenshot below.

e

X I Applications > Create

= Registration

= Connectors Save Cancel
~w Application Center
| Name:* HYPERION
= Systems
b Utiliies | Description:* HYPERION_HFW|

~ Logs Monitor

= Application Log

Figure 5.2: Application>Create
5. In the Name field, enter appropriate name of the application.
6. In the Description field, enter appropriate description of the application.
7. Click Save to save the newly created application.

Once the applications details are saved, it is listed on the
Application>Search page. The screen displays message as, "<Application
Name>: Application created successfully."

5.1.3 VIEW/MODIFY APPLICATION

The steps to view/modify the application are as follows.

1. On the Application>Search page, click the select column corresponding
to the application name, which you want to view/modify.

2. Click on Open button.

The Application>Open page opens as shown in the following screenshot.

T

* I Applications = Open

» Registration

= Connectors Save Cancel
w Application Center
Applications .
| Name: HYPERION
= Systems
b Utiities | Description= HYPERION_HFM

w Logs Monitor

= Application Log

Figure 5.3: Application>Open
3. The Name field is not editable.
4. Edit the Description as required.
5. Click Save to save and update the changes.

Note: the Description is editable until the time Application is not
registered or until it is in process of registration. Once it is
Registered, Application details cannot be edited.
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5.2 SYSTEM

After defining the Application, you can create a system and associate it with the
application. Apart from this, you can associate the connectors with the system. All
the connectors (that have been created through Connector screen) are available
through Add Connector button on the System Screen.

521 SEARCH SYSTEM

A search criterion helps to find the previously created systems. The search
criterion helps you to search a particular system or find all the existing
systems in one go.

The steps to search the system are as follows.
1. Click the Configuration tab.
2. In the left navigation pane, click the Application Center>Systems.

The Systems>Search page opens as shown in the following screenshot.

Welcome sapuser [ Administrator | Help | About | Logout
AGGLSE YIDLATION MANAGEMEKT
——

C——

# I Systems = Search

= Registration
= Connectors Create | Delete | Open |
~ Application Center
o LRI | Mame:
» Utilities | Description:
~+ Logs Monitor | Appiicstion:
= Application Log Go
Select Id Name ¢ Xemal SISt peseription Appligation
O |z000 RLEARSYS RLEARSYS RLEARSYS RTADS 2.0 SPOS

Figure 5.4: Systems>Search
3. To view all the existing systems, click Go.
-Or-
To view a particular application, enter the parameter value in the
Name/Description/ Application field and click on Go.

4. The records are displayed under the column headings Select, Id, Name,
External System Id, Description and Application.

5.2.2 CREATE A SYSTEM

The steps to create a new system are as follows.
1. Click the Configuration tab.
2. In the left navigation pane, click the Application Center>Systems.
The Systems>Search page opens.
3. Click on Create.
The Systems>Create page opens as shown in the following screenshot.
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I Systems > Create

Save Cancel
| Name:*
| Description:*
| External System Id-*
| Application:* [~setect ~]
| Status: [actve ~]
| System Type: ISOD ﬂ
| SOD Datasource Connector: [~Select- ~]
| RTADS Repository: 0
» System Paramters Count O Mote : "Please save System Parameter changes to take effect”
Add Connector
Select Id Connector Connector For Description Connection Type

Figure 5.5: Systems>Create
4. In the Name field, enter appropriate name of the system.
5. In the Description field, enter brief description of the system.

6. In the External System Id field, enter appropriate id.

Note: the System creation has one External System Id associated that
denotes the exact name of the System that is configured into the
SAP RAR. There is one to one mapping between the System Name
and the External System Id and the validation has been placed for
the External System Id to be unique.

7. In the Application drop-down list, select appropriate application. This
field is mandatory.

8. In the Status drop-down list, and select the status as Active.

9. In the SOD Datasource Connector dropdown list, select appropriate
value.

Note: the SOD Datasource Connector dropdown list displays all the
active connectors. This field is not mandatory. This setting is
required for upload SOD. If you are not using Upload SOD or
Offline feature this configuration is not required.

Mark the AVM-RTADS Repository checkbox. When you check the
RTADS Repository checkbox, you can conduct offline analysis. Instead
of real time call, you can fetch data from AVM-RTA DS table. This feature
is added for performance enhancement. For More information on this
refer, Chapter 14 Appendix. When the AVM-RTADS Repository
checkbox is not checked, it indicates you need to do online (Real time)
analysis. In that case, while creating Autobatch Extraction, under the
Adapter Manager> Auto Batch Extraction>Job Scheduler-Create page,
the Create File checkbox is by default checked and non-editable. Files are
auto generated. When the AVM-RTADS Repository checkbox is
checked, it indicates offline analysis mode. In that case while creating
Autobatch Extraction, under the Adapter Manager> Auto Batch
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10.

11.
12.

13.

Extraction>Job Scheduler-Create page, the Create File checkbox is not
checked and is editable. You can create .zip files as required.

Click on the Add Connector button.
The Connector page opens displaying the list of connectors under the

column headings Select, Connectors and Description as shown in the
screenshot below.

Connector [

[] JoBC ‘JDBC

PLCONN ‘ s e )

O
O REQUEST DETAILS_WS CONN‘ Connector for webservice
L]

USER _ACCESS_WS_CONN ‘Connector for webservice

Figure 5.6: Connector
Click on Select, next to the connector, which you want to add.
Click on Select button.

The connector is added to the system and is displayed under the column
headings Select, Id, Connector, Connector For, Description, and
Connection Type.

Systems > Open

Save Cancel

l1d 2002

| Name:* ARIBA

| Description ARIBA

| External System Id* ARIBA

| Application:= [AriBA v
| Status: |Aclwe
| System Type [soD
| 30D Datasource Connector: I"SEIECI_
| RTADS Repositary: O

Add Connector | Remove Connector |
--———
() 2000 JOBC [v] JoBC |.IDBC

Flgure 5.7: Systems>Open

Note: under Informer>Report, when you click Run Report, at that time
only that connector is selected for which Connector For type is
Report.

To add new parameter, click on the arrow image corresponding to the
System Parameter.

The following screen opens.
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|1d

| Mame:*

| Description*

| External System Id:*
| Application:*

| status:

| Systermn Type:

| S0D Datasource Connecior.

2002

ARIBA
ARIBA
ARIBA

|Active

|soD

[-select-

Systems > Open
sane |
Registration : REGISTERE

| RTADS Repository: D

| IMPORT_PROFILE: ARIBA

e
| Country: UK (-]
(4]

Add Connector

Remove Connector

Figure 5.8: System Parameters

Note: It is mandatory to enter system parameter as
IMPORT_PROFILE for importing CSV Data. The Configuration
tab> Utilities> Import CSV Data screen displays only those
systems for which system parameter is added as
IMPORT_PROFILE.

14. Enter appropriate name and parameter value. Click on Save. The screen
displays message as, “<Name>: System updated successfully.”

15. Click on the Edit image J . Below screen opens.

Systems > Open

Save Cancel

ld 2002

| Name:* ARIBA

| Description:=

| External System Id:*

| Application:*

| status:

| System Type:

| SOD Datasource Connector:

| RTADS Repository:

| IMPORT_PROFILE

ARIBA
ARIBA

[Active

|sco

|-Select—

||Country.

Add Connector

Registration : REGISTERED

Remove Connector

Figure 5.9: System Parameter

16. Edit the Parameter Value as required and click Save to save the system.

17. Click on the @ Delete image to delete the selected parameter.

18. Click on Save to save the newly created System.
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The System>Search screen displays message as SYSTEM NAME: System
created successfully.

19. Once the Systems details are saved, they are displayed on the

System>Search page.

Note: the System and Application Name created in these screens will be

available for all the screens where in System and Application fields
are present. The Registration Status of the Application and System do
not hamper these to be available in other screens (like Custom Adapter
configuration, Add System -Connector Screen). However, the APIs
attached to the system will only function if the system is registered.

5.2.3 VIEW/MODIFY SYSTEM

The steps to view/modify the system are as follows.

1.
2.
3.

4.

Click the Configuration tab.

In the left navigation pane, click the Application Center>Systems.

On the System>Search page, click the select column corresponding to the
System Name which you want to view/modify.

Click on the Open button.

The System>Open page opens displaying the details of selected system
in each field as shown in the following screenshot. The screen displays
the details of associated connectors under the column headings Select, Id,
Connector, Connector For, Description, and Connection Type.

Systems > Open

Save I Cancel

l1g 2000
| Name:® SFSF1
| Description:* SFSF1

| External System Id:* SFSF01

| Application* I

| Status: [Active

| System Type: |Emergency Access

| SCD Datasource Connector,

| RTADS Repository:

Ml System Paramiers

Select 1d ‘Connector

() 2001 |GLT_LOCAL

() 2000 |SFSF_CONN

[EE <

[-select-

O
Count 11

Connector For

Mote : "Please save System Parameter changes to take effect”

Add Connector

Remove Connector

Description

[RAR

[ | JNDI Connector

B

v | Successfactors Webservice Connector

Connection Type
JNDI

SFWS

Figure 5.10: Systems > Open
To remove the associated connector, select the connector and click on the
Remove Connector button.
The associated connector is removed from the system.

Note: if the system is registered then you cannot remove connector
associated with it.
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To add a new connector to the system: follow the steps 10 to 12 under
Create System.

Click Add Parameter, the Parameter screen opens. Enter appropriate
parameter name and parameter value. Click Add to add the newly
defined parameter value.

Click Save to save and update the changes.

Note: once applied for registration the External System Id, the System
Name and Application name becomes non - editable. However,
the status of the System remains editable. Perform either Add or
Remove Connectors and save. Do not perform Add-Remove or
Remove-Add connector activity at a time. The RTA DS
application will consider only last action perform on UL

5.24 DELETING SYSTEM BY CHANGING ITS STATUS

You can delete a system in two ways:

1.
2.

Selecting a system and making its status Inactive.

Selecting a system and click on Delete button.

The steps to delete a system by changing its status are as follows.

1.
2.
3.

6.

Click the Configuration tab.

In the left navigation pane, click the Application Center>Systems.

On the System>Search page, click the select column corresponding to the
System Name which you want to delete.

Click on the Open button.

The System>Open page opens displaying the details of selected system
in each field as shown in the following screenshot. The screen displays

the details of associated connectors under the column headings Select, Id,
Connector, Connector For, Description, and Connection Type.

The Id, Name, Description, External System Id, Application fields are
not editable.

i Systems > Open

cancel

l1d 2000
| Name:* SFSF1
| Description= SFSF1

| External System Id:* SFSFO1

|Apphcaticn * I [

| status: | Inactive

| System Type | Emergency Access v

| SOD Datasource Connector: [~select- ~]

| RTADS Repository: D

Figure 5.11: Systems>Open
In the Status dropdown list, select the status as Inactive.

Greenlight Technologies, Inc. Page 31 of 123



( :beenlight
AVM- RTA Design Studio User Guide v2.0SP07 Tremmaea

7. Click on the Save button.

The Message dialog box opens as shown in the following screenshot.
Message from webpage |

9

\___./ You are about to delete syskem JDBC_SYS, Do wou want to continuey

(0] 4 I Cancel |

Figure 5.12: Message
8. Click on OK to delete the system.

The screen displays message as, "<System Name>: System deleted
successfully."

Note: once you select the status as Inactive, you cannot change it to
Active. You cannot change the status of the system which is
Registered and associated with connector.

5.2.5 DELETING SYSTEMS USING DELETE BUTTON

The steps to delete a system by clicking on Delete button are as follows.
1. Click the Configuration tab.
2. In the left navigation pane, click the Application Center>Systems.

3. On the System>Search page, click the select column corresponding to the
System Name which you want to delete.

[ systems > search
Create Open
| MName.
| Description,
| Application:
Go
Belect Id Name # External System Id Description Application
2015 GLT_SYS51 GLT_sys GLT_sys1 FRI_APP
|(l- 2020 GLT_VENDAVO_GRC10 VENDAVOG10 GLT_VENDAVO_GRC10 System | GLT_VENDAVO_GRC1

Figure 5.13: Systems> Search
4. Click on the Delete button.

The following message appears on the screen.

%
i?-.

\__,/ You are about to delete syskem . Do wou want bo conkinue?

(0] 4 Zancel

Figure 5.14: Message
5. Click on OK to delete the system.

Note: If the system is mapped with connectotr/API, you cannot delete it.
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6 REGISTRATION

For importing and configuring the API Information, the registration of the
application and System are required. First register the application then register the
system.

If the Application is in-progress or registered then only you can register the system.

6.1 REGISTERING AN APPLICATION

For importing and configuring the API Information, the registration of the
application and system are required. After registering the application and system,
the external system id will become non-editable. Hence, before registering the
application/system, verify the connector name of GRC and external system id.

First, register the application then the system.
The steps to register an application are as follows:
1. Click the Configuration tab.
2. Click Registration in the left menu bar.
The Registration >Application - System>Search screen opens.

AGGLSE VIDLATION MANAGEM LKT
e —————————

Help | About | Log

out

C—

X Registration > Applications- Systems > Search

Registration

= Connectors Open
 Application Center
= Applications | Name: |T -
3 ype: - — v
+ Systems |-Select: v
} Utilities | Description: | Status: |--Se|ect-- ﬂ
w Logs Monitor | Customer Name:
= Application Log Go
Select Name ¢ Description Customer Name Type Status
(® |ORACLE Ora apps APPLICATION NOT REGISTERED
() |PB_SYS PITNEY-BOWES System 2 SYSTEM REGISTERED

Figure 6.1: Registration > Application- Systems > Search
3. To find all the previous records, click Go.
-Or-
To find a particular parameter, enter the value in the
Name/Description/ Customer Name field and click Go.

4. The screen displays search results under the column headings Select, Name,
Description, Customer Name, Type and Status.

5. Select Application whose status is non-registered.
6. Click on Open.
The Registration screen opens as shown in the screenshot below.
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Help | About | Logout
AGGESS YIOLATION MANAGEMENT
r ' Configuration
X Registration
Registration
- Connaciors
v Application Center Registration : NOT REGISTERED
= Applications
- Systems | Customer 1d: GLT
b Utilities |
Customer Name:* i i
+ Logs Monitor Greenlight Technologies
+ Appiication Log | Contact Person Greenlight Technologies
| Email Address: admin@gresnightcomp.com
| Telephone:®
| Address* Pune
| Application Name:* ORACLE
| Operating System:*
| Datssource Type:® |—Se|ect—-
| Access Control Version™ |—Se|ect—-

Figure 6.2: Registration
The Customer Id field is non-editable.

In the Customer Name text box, enter appropriate Customer Name.

@

In the Contact Person text box, enter appropriate name.
10. In the Email Address text box, enter appropriate contact mail address.
11. In the Telephone text box, enter appropriate contact number.
12. In the Address text box, enter appropriate customer address.
13. The Application Name fields are non-editable.
14. In the Operating System text box, enter appropriate operating system.
15. In the Datasource Type dropdown list, select appropriate value.
16. In the Access Control Version dropdown list, select appropriate value.
17. Click Save.

18. The screen displays message as shown in the below screenshot.

‘Welcome Admin [ Admin Admin ]
AGGESTS VIOLATION MANAGLMW EHT

Help | About | Logout

r ' Configuration
b Registration = Applications- Systems > Search
Registration
0 ErnEe 0 pa y Please upload the license key.
 somncne e |
» Applications
= Systems
= e | Name: | Type: [~Seteet-
~+ Logs Monitor | Description: | status: [l
- Application Log | Customer Name:
[0]
SclctMeme s Deseripfon  CusbmerName  Type  Smwe |
O |oRracLe Ora apps ngﬁﬁgtlggﬂas APPLICATION IN-PROCESS
() |PBE_SYS PITNEY-BOWES System | 5 SYSTEM REGISTERED

Figure 6.3: Registration > Application- Systems > Search
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19. Select the application and click on the Open button.

20. The below screen opens.

ACCESE WIDLATION MANAGIMEHT

r ' Configuration

® Registration

Registration

= Connectors

w Application Center

| Mame: ORACLE
P ApElIETETE | Description: Ora apps
* Systems | Type: APPLICATION
b Hilies | License Key:* Browse...
+ Logs Monitor

Figure 6.4: Registration

21. Click on the Browse button and import the GLT_RTADS_APPL.XML license
key provided in the build.

22. Click on Save.
23. The screen displays message as shown in the following screenshot.

Help | About | Logout
AGGESS YIDLATION MANAGEMENT
r ' Configuration
X I Registration = Applications- Systems > Search
Registration =
= Connectors Lo B
~ Application Center Open
= Applications
= Systems |Name' |T -
Z ype: --Select- e
¥ Utiities I
< e | Deseription: | Status [~seiect—
= Application Log | Customer Name:
[e=]
N =
GREEMLIGHT
() |ORACLE Ora apps TECHNOLOGIES APPLICATION REGISTERED
() |PB_SYS PITNEY-BO'WES System 5 SYSTEM REGISTERED

Figure 6.5: Registration > Application- Systems > Search
24. After saving the application its status changes to REGISTERED.

6.2 REGISTERING A SYSTEM

The AVM-RTA DS application processes the GRC requests only after the system
is registered. Before registering the system, ensure to register the application.

You can register the system only when, the application status is in-progress and
its status is registered.

Note: if the configuration for the system in AVM-RTA DS and GRC side is
complete then you can schedule the jobs from GRC.
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The steps to register an application are as follows:
1. Click the Configuration tab.
2. Click Registration in the left menu bar.
The Registration >Application - System>Search screen opens.

Welcome Admin [ Admin Admin ] Help | About | Legout
AGGLSE YINLATION MANAGEMEHT
S —
# Registration > Applications- Systems > Search
Registration
= Connectors Open
- Application Center
= Applications | Name IT .
ype: i - ~
. Systems |--Select: v |
» Utilities | Deseription: | Status |--Se|ect—- ﬂ
w Logs Monitor | Customer Name:
= Application Log Go
Select Mame + Description Customer Name Type Status
~ GREEMLIGHT o
() |ORACLE Ora apps TECHNOLOGIES APBLICATION REGISTERED
(@ | ORACLE_SYSTEM Oracle_System SYSTEM NOT REGISTERED
) |PB_SYS PITMEY-BOWES System 5 SYSTEM REGISTERED

Figure 6.6: Registration > Application- Systems > Search
To find all the previous records, click Go.
-Or-
To find a particular parameter, enter the value in the
Name/Description/ Customer Name field and click Go.

3. The screen displays search results under the column headings Select, Name,
Description, Customer Name, Type and Status.

4. Select the System whose status is non-registered.
5. Click on Open.
The Registration screen opens.
6. The Customer Id field is non-editable.
7. In the Customer Name text box, enter appropriate Customer Name.
8. In the Contact Person text box, enter appropriate name.
9. In the Email Address text box, enter appropriate contact mail address.
10. In the Telephone text box, enter appropriate contact number.
11. In the Address text box, enter appropriate customer address.
12. The Application Name fields are non-editable.
13. In the Operating System text box, enter appropriate operating system.
14. In the Datasource Type dropdown list, select appropriate value.

15. In the Access Control Version dropdown list, select appropriate value.
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Gheeniight

AGGESS YIOLATION MANAGEM EHT

Welcome Admin [ Admin Admin ]

Help | About | Logout

| Email Address:*

| Telephone:*

| Address

| System Name:*
| Application Name:*

| Operating System:*

| Datasource Type:*

| Access Control Version™

r ' Configuration
X Registration

+ Camecor
~ Application Center Registration : NOT REGISTEREQ]

- Applications

= Systems | Customer Id:* GLT
b Utilities
« Logs Monitor | Gustomer Name:* Greenlight Technologies

+ Application Log | Gontact Person:* Greenlight Technologies

admin@greenlightcorp.com

819576580

Pune

ORACLE_SYSTEM
ORAGLE

Windows

|Relalional Database

- |

16. Click on Save.

Figure 6.7: Registration

17. The system is listed on the Registration screen.

18. Select the system with status as In-Process and click on Open.

19. The below screen opens.

ACCESE VIDLATIOH MANAGCMEHT

[

Configuration

y

% I Registration
= Connectors
v AR & |Name:
o REETELETD | Description:
= Systems
o | Type:
» Utilities
| License Key:=
 Logs Monitor
= Application Log

QORACLE_SYSTEM
Oracle_System
SYSTEM

Browse...

Figure 6.8: Registration > Application- Systems > Search
20. Click on the Browse button and import the GLT_RTADS_SYS.XML license

key provided in
21. Click on Save.

the build.

22. The screen displays message as shown in the following screenshot.
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ACCLSS YIOLATION MANAGIMEHT

Configuration

X I Registration > Applications- Systems > Search

Help 1 About | Logout

[eo]

() |ORACLE

+ Connectors Registration Key saved successfully.
w Application Center Open
+ Applica
= BEETE | Name:
b Utilifies
-l Monitor | Diescription:
- Application Log | Customer Name:

| Type:

| Status:

GREENLIGHT

|-Setect-

| -Select-

Ors apps ECHNOLOGIES APPLICATION REGISTERED
GREENLIGHT
() |ORACLE_SYSTEM Oracle_System e SYSTEM REGISTERED'

Figure 6.9: Registration > Application- Systems > Search
23. After saving the system its status changes to REGISTERED.
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7 UTILITIES

Using the Utilities feature, you can import master data as well as adapters and can
configure flat files.

7.1 IMPORT MASTER DATA

The steps to import master data are as follows.
1. Click the Configuration tab.
2. Click the Utilities>Import Master Data.

The Import Master Data page opens as shown in the following screenshot.

I Import Master Data

| Waster Data File(Local):* Browse..

| overwrite |

Import

Figure 7.1: Import Master Data
3. Click on Browse button.

4. In the Choose File to Upload window, select appropriate XML file to be
uploaded and click Open.

5. The file path is displayed in the in the Master Data File (Local) text box.

6. Click on the Import button. The application prompts with the message,
“Master data imported successfully”.

7. To overwrite the previously imported master data xml file, click on
Overwrite and re-import the master data.

Overwriting the xml file deletes all the adapters and programs defined in the
RTA DS application.

7.2 IMPORT ADAPTER

The Import Adapter screen asks for the Adapter Name and the Application
Name and asks for the XML file to be imported. The XML File once properly
imported will create the programs in the Program Definition and Program
Configuration screens.

The steps to import the adapter are as follows.
1. Click on Configuration tab.
2. In the left navigation pane, click on the Utilities> Import Adapter link.
The Import Adapter Data screen opens as shown in the following screenshot.

Greenlight Technologies, Inc. Page 39 of 123



Geentiont

AVM- RTA Design Studio User Guide v2.0SP07

7.3

—_—
T
X I Import Adapter Data
* Registration
= Connectors
» Application Center
w Utilities
- Import Master Data | Appiication - [—select— =l
Import Adapter | GRC Application : [setect- =
= FlatFile Configuration
= Upload SOD Rules | Adapter Metadata(Local) . * Browse.
= Upload S0D Rules Configuration | overwrite -
= AutoBatch Configuration
Import
w Logs Monitor L
- Application Log

Figure 7.2: Import Adapter Data
3. In the Application dropdown list, select appropriate application name.
4. Inthe GRC Application dropdown list, select appropriate application.

5. Click Browse button and select appropriate xml file in the Adapter Metadata
(Local) text box.

6. Click and select the Overwrite checkbox.

If the checkbox is checked, the standard adapter's components such as
Program Definition, Program Configuration, and Adapter to Program
mapping and Program to API field mapping are over written.

If the overwrite checkbox is not checked the standard adapter is imported.
7. The validation checks are as follows.
a. The Program name imported through the xml is unique.

b. The data types of the program output fields imported through xml
should match with the master data for the output fields defined in the
RTA tables.

c. All the API fields stated in the xml should be present in the master data
tables of RTA.

d. The output field names to which the API fields are mapped should be the
same as defined in the section for Programs in the same xml.

8. Click Import.
The adapter is imported.

IMPORT CSV DATA

This section discusses about importing Ariba relevant CSV for a particular
system.

The systems displayed here are created under the Configuration tab>
Application Center> Systems. Only those systems are populated in the
dropdown which are registered and for which IMPORT_PROFILE parameter is
added.

The steps to import CSV data are as follows:

1. Click on Configuration tab.

2. In the left menu bar, click on the Utilities> Import CSV Data link.
The Import CSV Data screen opens.

3. In the Systems dropdown list, select appropriate system.
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Note: the System dropdown lists, systems created under Configuration tab>
Application Center> Systems.

R

® I Import CSV Data

= Flat File Configuration

» Upload 50D Rules Impeort

= |Jpload SOD Rules Configuration

= Registration
= Connectors
» Application Center
w« Ultilities
Systems :
= Import Master Data |5 EESE v
= Import Adapter | Rtwa:
Import C3V Data InvoiceTypeldentifisrLanguage.csv Browse.
InvoiceExceptionTypeOverideDriver csv Browse.__

Figure 7.3: Import CSV Data
4. Based on the selected system its mapped realm profiles are displayed.

Note: The system displays only those realm profiles which are
mapped to system. The Realm Profiles are mapped to System
by adding System Parameter value of Realm for the System
Parameter IMPORT _PROFILE. The Realim Profiles are
created under the Configuration tab> AVM Import/Export
Configuration> Define Realin Profile. Click on Browse, select
appropriate .CSV file.

5. Click on the Import button.
The screen displays message as, "CSV files Uploaded Successfully."

74 PROPERTIES

Property feature is introduced to list all the properties available in the AVM-RTA
DS application on GUI These properties are maintained in the
rtads_application.properties file. This properties file is loaded while application
server starts-up and values are available for use, throughout application.

By default when the application is deployed all the values available in the
rtads_application.properties file are displayed on the UL

74.1 SEARCH PROPERTIES

The search criterion helps to find previously all the existing AVM- RTA DS
properties in one go or search particular AVM- RTA DS property.

The steps to search the Properties are as follows.
1. Click on Configuration tab.
2. In the left navigation pane, click the Utilities> Properties.

The Properties > Search page opens as shown in the following
screenshot.
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Informer Adapter Manager

= Registration

x I Properties > Search

Configuration

= Connectors
» Application Center
w Utilities
= Import Master Data
= Import Adapter
= Import CSV Data

= Flat File Configuration
= Upload SOD Rules

= AutoBatch Configuration
= Application Configuration
= Import Files

= Key Management

w Logs Monitor
= Application Log

= Upload SOD Rules Configuration

¥ AVM Import/ Export Configuration

Impart Expart Server needs to be restarted, for changes to take effect

| Key

| value

| Default Value:
| Description :

| Order By -

]
]
]

c3]

éu (Search is case sensitive)

Bxpand |
Select Collapse  Key
o

AD BATCHSIZE

AD REFRRAL

AD.SECURITY.AUTHENTICATION

ADVERSION

AMP

ARIBA DEACTIVATEDSHAREDUSER TABLE

L ]
L ]
L ]
L ]

|Va|ue and Default Value - MATCHING v

Value Default Value In-Memory Value

1000 1000 1000

follow follow follow

simple simple simple

3 3 3
Mahesh Punde

Mahesh Punde Mahesh Punde

GLT_XPA_GEN_TAED2 GLT_XPA_GEN_TABD2

Figure 7.4: Properties > Search

3. To streamline the view, enter appropriate value in the
Key/Value/Default Value/Description fields. Alternatively, select
appropriate value in the, Order By dropdown list from the options given
in below table and click on the Go button.

Value and Default Value | Properties for which value and default values are matching
- MATCHING are listed on top.
Properties for which value and default values are not
matching are listed at bottom.
Value and Default Value | Properties for which value and default values are not
- NOT MATCHING matching are listed on top.

Properties for which value and default values are matching
are listed at bottom.

Value and In-memory
value - MATCHING

Properties for which value and in memory values are
matching are listed on top.

Properties for which value and in memory values are not
matching are listed at bottom.

Value and In-memory

Properties for which value and in memory values are not

value - NOT matching are listed on top.
MATCHING Properties for which value and in memory values are
matching are listed at bottom.
-Or-

Click on the Go button.

Note: the Search is case sensitive.

4. Based on the search criterion the information about properties is
displayed under the column headings Select, Expand/Collapse All, Key,
Value, Default Value and In- Memory Value.

5. The below table explains description about each column name.

Key Property Key Name.
Value Property Key Value. You can change this value as per
requirement.

Greenlight Technologies, Inc.

Page 42 of 123

GLT_XPA_GEN_TAB02




Geentiont

AVM- RTA Design Studio User Guide v2.0SP07

Default Value Default value of property. Cannot be changed.
In-Memory Value | Indicates the value currently used by Application server.
Description Detail description about the property.

Note: Expand or collapse option is provided to view full text
values.

74.2 IMPORT PROPERTIES

The Import Properties allows updating more than one property values at a
time. You can import a file of type “properties’.

The file should contain existing keys (which are already present in table) and
values for corresponding keys. System updates values in table.

The steps to import the rtads_application.properties file are as follows.

1.
2.

Click on Configuration tab.

In the left navigation pane, click the Utilities> Properties.
The Properties > Search page opens.

Click on the Import button.

The Import Properties screen opens.

Import Properties [

Import Cancel

File Browse...

Figure 7.5: Import Properties

Click on the Browse button and select the rtads_application.properties
file.

Click on the Import button.

Note: Server needs to be restarted, for changes to take effect. Import
functionality does not help user to add new properties. This
is to update values for multiple keys in a single go.

74.3 EXPORT PROPERTIES

The Export Properties allows exporting all the existing properties (keys and
corresponding values )into rtads.properties file. You can save it on local
machine.

The steps to export the rtads_application.properties file are as follows.

1.
2.

Click on Configuration tab.

In the left navigation pane, click the Utilities> Properties.
The Properties > Search page opens.

Click on the Export button.
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File Download [

Do you want to open or save this file?

I Mame: rtads.properties I

Type: properties_auto_file, 749 bytes
From: localhost

COpen ] [ Save ] [ Cancel ]

= “w | While files from the Intemet can be useful, some files can potentially
a ham your computer. f you do not trust the sounce, do not open or
= save this file. What's the risk?

Figure 7.6: File Download
4. Click on the Open button to open the file.
5. Click on the Save button to save the file on your machine.

74.4 EDIT PROPERTIES

The Edit Properties allows editing particular property.
The steps to edit properties are as follows:
are as follows.
1. Click on Configuration tab.
2. In the left navigation pane, click the Utilities> Properties.
The Properties > Search page opens.
3. Select appropriate property.
4. Click on the Edit button.
The Properties Edit Page opens as shown in the below screenshot.

Properties Edit page

Save Cancel

Key: AD BATCHSIZE
. 1004 s
Value:
W
. 10040 )
Default Walue:
W
AD.BATCHSIZE
~
Description :
W

Figure 7.7: Properties Edit Page
5. Click on the Save button.

Note: Server needs to be restarted, for changes to take effect.
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6. The Properties > Search page displays message as, “Property updated

successfully”.

Note: The column IN-MEMORY Value shows the values that are used by
application server currently. If In-Memory value and Updated

property values are different, it is highlighted with Red color.

7.5 FLAT FILE CONFIGURATION

You can do the Flat File Configuration for the systems, which provides data for

risk analysis through Flat Files.

The steps for Flat File Configuration are as follows.
1. Click on Configuration tab.

2. Click Utilities> Flat File Configuration.

The Flat File Configuration screen opens as shown in the following

screenshot.

C——

x I Flat File Configuration

= Upload SOD Rules Configuration
= AutoBatch Configuration
= Application Configuration

= Registration
= Connectors Create
» Application Center | System Name
w Utilities
o | Flat File Connectors:
= Import Adapter | JDBC Connectors:
= Import CSV Data
= Properties JGO
Flat File Configuration
= Upload SOD Rules. Select System # Flat File Connectors JDBC Connectors Frequency Start Date End Date Next Run Date Status

Figure 7.8: Flat File Configuration
3. To create new configuration record, click on Create.

The Flat File Configuration > Create screen appears as shown in the
following screenshot.

L

% ] FiatFile Configuration > Create

» Import Files

= Key Management
}» AVM Import/ Export Configuration.  GLT_XPA_GEN_TABO4
+ Logs Monitor GLT_XPA_GEN_TABIS

GLT_XPA_GEN_TABD3

» Appiication Log GLT_XPA_GEN_TABUS
GLT_XPA_GEN_TABD7
GLT_XPA_GEN_TABDZ
GLT_XPA_GEN_TABDS

GLT_XPA_GEN_TAB1D

= Registration

= Connectors Save Next Cancel

» Application Center
Utilities

- | system: * [FSeie <]
= |mpori Master Data
» Import Adapler | JDBC Connector: = [~Seect <]
= Import C8V Data | Flatfile Connector * [~Seteet- ~
= Properties

Flat File Configuration

= Upload SOD Rules Table Name File Name Ignore Lines (Use Comma to enter multiple lines) Delimiter Covering Character
= Ugioad SOD Rules Configuralion | ) 1 woa GEN_TABDT
= AutoBatch Configuration
= Application Configuration GLT_XPA_GEN_TAB02

Figure 7.9: Flat File Configuration>Create
4. In the System dropdown list, select an appropriate system name.

a. In the JDBC connector, select an appropriate connector. The JDBC
connection loads data into the RTA DS database. It reads data from

the flat files pointed by the Flat File Connector.
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10.
11.

12.

b. In the Flat file Connector, select an appropriate connector. The Flat
File Connector points to the FIP location where the source files
resides.

c. Enter in the Filenames to store into the tables, specified under Table
Name column.

The filenames against the tables named as GLT_XPA_GEN_TABO1 to
GLT_XPA_GEN_TABI10.

The Ignore Lines (Use Comma to enter multiple lines) column, specifies the
lines in the files that are not be read into the tables.

The Delimiter specifies the entity that distinguishes one column data from
the other.

The Covering Character column contains the data with the delimiter
character that has to be read as one column data. For example if the name in
the file provided is John, Smith and it needs to be stored in one column then
the file should have covering characters enclosing this entity as “John,
Smith”.

Once all the details are specified, the AVM-RTA DS system is ready to load
the data into the AVM-RTA DS database.

Click on Save to save the configuration and load it later.

Or else click on the Load Data to Save the configuration and as well load the
data reading from the flat files.

Note: it is recommended that once the programs are defined and the data is
loaded entering the configuration. Do keep the file configuration as it
is. Else, care needs to be taken for the programs if the flat file
configurations are changed. The Files kept at the source can be zip
files or the .csv files; if there are any zip files present on the source
then priority will be given to these zip files to be read. Also if there
are zip files then this need to be present in MMDDYYYY n.zip; so
that the AVM-RTA DS automatically sorts to get the latest zip and it
unzips the zip files to get the set of files specified in the Filename
column on the Flat File Configuration>Create screen.

Click on Next to schedule upload of files based on the frequency apt to the
business requirements the Flat File Configuration>Schedule screen appears
as shown in the following screenshot.
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I Flat File Configuration > Schedule
% Schedule Cancel
| Frequency: @ yepiateLy
© once s
O DAILY At Every hr min
O WEEKLY On Every Sun Mon Tue Wed  Thu  Fri  Sat
hr min
O MONTHLY On Every Day hr min
| start Date : =
| End Date ]

Figure 7.10: Flat File Configuration>Schedule
13. Click on Schedule.

The application displays the message as, “<System Name>: Details saved and
Flat file load data scheduled successfully.”

7.6 UPLOAD SOD RULES

The SOD is the segregation of duties. For risk analysis, GRC uses the actions and
permissions data (of users/ roles) for which SOD rules are defined. The Upload
SOD Rules feature is designed to filter SOD rules data (actions/permissions).
The “Upload SOD Rules” functionality uploads the SOD rules from GRC table to
custom table in ERP. In the custom table the SOD Rules for given system are
stored. RTA uses SOD rules data in the ERP custom table to filter the actions and
permissions data for users/roles. This filtering is done for real time analysis as
well as analysis using RTADS repository. In turn, this reduces the returned data
volume to GRC. In addition, helps to improve the performance for both real time
analysis and analysis using RTADS repository. Before uploading SOD rules,
ensure to set upload SOD Rules Configuration.

Note: If you are not using Upload SOD or Offline feature this configuration is not
required.

7.6.1 SEARCH UPLOAD SOD RULES

The search criterion helps to find previously uploaded Sod Rules information
for a particular system or find all the existing uploaded Sod Rules
information for all the system in one go.

The steps to search the upload SOD rule information for system/systems is
as follows.

1. Click on Configuration tab.
2. In the left navigation pane, click the Utilities> Upload SOD Rules.
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The Upload SOD Rules page opens as shown in the following
screenshot.

= Define Realm Profile
= Define Import/ Export Profiles

C—T
% ] Upload SOD Rules
= Registration
-+ Connettors Last Job Details
¥ Application Center Add Systems Import SOD Config XML Upload SOD Rules Remove SOD Rules
- Utilties
= Import Master Data | Name: | External System ld:
* Import Adapter
+ Import CSV Data | Description: | Rules Uploadet! [~Selec- ™~
. | Last Run Date: Jus] | SOD Config XML Uploaded [Seiect~ ~
- Flat File Configuration
Upload SOD Rules. | Last Run Status [Select- 2! | Last Run Type [Seer =
* Upload SOD Rules Configuration Go
» AutoBatch Configuration [
- Application Configuration s Pase All Pases/ Reset
= Import Files - st — o
* Key Management okt g Name # Sxtemaly  Descipon  SOD  Successfuly  Successiully Fiter LastRunDate LastRunBy S2SIRUN Gomments Run
« AVM Importf Export Configuration S Rules UpdatedOn  UpdatedBy Configuration Szl Type

o1

Figure 7.11: Upload SOD Rules
To streamline the view, enter appropriate value in the
Name/Description/External System Id/Last Run Date fields.
Alternatively, Select appropriate value in the, Rules Uploaded/SOD
Config XML Uploaded/Last Run Status/Last Run Type dropdown list
and click on Go.
-Or-
Click on the Go button.
Based on the selected criterion the screen displays details under the
column headings Select, Id, Name , External System Id, Description,
View SOD Rules, Last Successfully Updated On, Last Successfully
Updated By, View SOD Filter Configuration, Last Run Date, Last Run
By, Last Run Status, Comments, and Last Run Type.
The Id column displays the unique identification number of the system.
The Name column displays the name of the system.
The External System Id column displays the id defined while creating the
system.
The Description column displays the description given while creating the
system.
The View SOD Rules column displays the count of SOD entities. Under
the View SOD Rules column, click on the View link.
The View SOD Rules page opens as shown in the following screenshot.
The information about the rule is displayed under the column headings
SYSTEMID, ACT and IS_RULE and COL1, COL2, COL3, COL4, and
COLS5.
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View SOD Rules - KOEL £}

View 50D Rules

Close

SYSTEMID ACT I5_RULE COL1 coLz CoL3 CoL4 COL5

RAR_ORACLE| AP _APXINWKB_ACCOUNTING

RAR_ORACLE| AP_APXINWKB_ACTIONS

RAR_ORACLE| CLR0O252A

RAR_ORACLE| AP_APXPAWKB_PRINT_BATCH

RAR_ORACLE PO_POXPOERL

RAR_ORACLE/ PO_POXRQERQ

RAR_ORACLE| INV_INVADPTE

RAR_ORACLE APXVDMVD

RAR_ORACLE RVCTRI/PO

RAR_ORACLE|AP_APXPAWKB_FORMAT_BATCH

RAR_ORACLE| AP_APXINWKB_SUMMARY

Figure 7.12: View SOD Rules

9. The Last Successfully Updated On column displays the information on
SOD rules successfully uploaded/removed last time for given system in
yyyy-MM-dd hh:mm:ss format.

10. The Last Successfully Updated By column displays the name of the login
user who successfully upload/ remove SOD rules last time for given
system.

11. Under the View SOD Filter Configuration column, click the View link.

The View SOD Filter Configuration page opens as shown in the

following screenshot.

Note: the View link appears only after uploading SOD Rules.

View SOD Filter Configuration - RAR_ORACLE

I View SOD Filter Configuration

Close

Checkpoints as of the current loaded xml

Current XML Configuration Loaded On: 04-04-2013 08:58:43 Loaded By: SAPUSER

# #
Type Seq# P 0P Connector
UPLOAD 1 @IPE#1=PEARSON ACTION_NAME JOBC_COMNN
UPLOAD 2 @IP#1=PEARSON ORACLE_CONM

@IP#1=PEARSON
@IP#2=##0PERATION:ID#1:ACTION_NAME
@IP#3=

UPLOAD 3 %:Eigz ORACLE_CONN
@IP#e=
@IP#T=
@IP#e=

UPLOAD 4 ORACLE_CONM

CLEAN 1 @IP#1=PEARSON ORACLE_CONM

Figure 7.13: View SOD Filter Configuration

a. The View SOD Filter Configuration page displays the details
imported using “Import SOD Config XML"” against the selected
system.
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b. The View SOD Filter Configuration page displays two sections
Checkpoints as of the current loaded xml and Current XML
Configuration Loaded On and Loaded By as shown in the above
screenshot. Click on the Bl image to view detail of each section. At
a time, you can view the detail of only one section.

c. Click the® image corresponding to the Checkpoints as of the
current loaded xml. The screen displays information as shown in
the following screenshot.

View SOD Filter Configuration - RAR_ ORACLE
I View SOD Filter Configuration
Close
Checkpoints as of the current loaded xml =
Please ensure the userid SAPSR30B have Read Privileges for the Tables residing on the datasource referenced by
Operationt
JDBC_COMNN
Operation2 Please ensure the userid PEARSON_QA_25MARZ013 have Delete Privileges for the Table GLT_DS_S0D_ACT
2 residing on the datasource referenced by ORACLE_CONN
Operations Please ensure the userid PEARSON_QA_25MAR2013 have Insert Privileges forthe Table GLT_DS_S0D_ACT
n residing on the datasource referenced by ORACLE_CONN
Operations Please ensure the userid PEARSON_QA_25MAR2013 have Execute Privileges for the Stored Procedure
get_rule_data residing on the datasource referenced by ORACLE_CONMN
Operations Flease ensure the userid PEARSON_QA_25MARZ2013 have delete Privileges on table GLT_DS_S0D_ACT residing
on the datasource referenced by ORACLE_CONM
0 tions Please ensure the userid PEARSON_QA_25MAR2013 have delete Privileges on table GLT_DS_SOD_ACT residing
IEELT on the datasource referenced by ORACLE_CONMN
Current XML Configuration Loaded On: 04-04-2013 08:58:43 Loaded By: SAPUSER

Figure 7.14: View SOD Filter Configuration
d. Click theE image corresponding to the Current XML
Configuration. The screen displays information as shown in the
following screenshot.

View SOD Filter Configuration - RAR_ORACLE

I View SOD Filter Configuration

Close

UFLOAD

UFPLOAD

CLEAN

4

1

Checkpoints as of the current loaded xml i+

Current XML Configuration Loaded On: 04-04-2013 08:58:43 Loaded By: SAPUSER =
2] 2]

Type Seq# P QP Connectar

UPLOAD 1 @IP#1=FEARSON ACTION_MNAME JOBC_CONN

UPLOAD 2 @IP#1=PEARSON ORACLE_CONN

@IP#1=PEARSON
@IP#2=##0PERATIONID# TACTION_NANE

@F#3=

%:Ex;’: ORACLE_CONN
@IP#o=

@P#r=

@lPHa=

ORACLE_CONMN

@IP#1=FEARSON ORACLE_CONN

Figure 7.15: View SOD Filter Configuration
e. Under the Current XML Configuration section, click on the &
image to expand and collapse information about the description
and program section, refer the following screenshot.
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12.

13.

14.

15.

16.

View S0D Filter Configuration - RAR_ORACLE
| View S0D Filter Configuration -

Cloze

Checkpoints as of the current loaded xml

Current XML Configuration Loaded On: 04-04-2013 08:58:43 Loaded By: SAPUSER

= =
Type Seq# Desc Program P Qip Connector
Querving | SELECT DISTINCT TRIM(SUBSTR
e Grgcg (AUTHTREE, 1 INSTR
RaR (AUTHTREE,T,1,1)-1))
Aoplication | ACTION_NAE FROIH
VIRSA_CC_FUNCPRU WHERE )
UPLOAD | 1 fftlfﬁﬁ.fe vavaRey I (SELECT @IP#1=PEARSON ACTION_NAME | JDBC_CONN
eal LVSYSKEY FROM
s tor | VRSA_CC_LSYSGRP WHERE
e ovaan | VSYSKEY=@P#1) OR
¥ VSYSKEY IN (@IP#1)
Deleting the
Z?chg%n DELETE FROM
"
UPLOAD | 2 | Rules e @IP#1=PEARSON ORACLE_CO ™

4 3

Figure 7.16: View SOD Filter Configuration
The Last Run Date column displays information on the SOD rules
upload/remove operation performed last time for given system in yyyy-
MM-dd hh:mm:ss format.
The Last Run By column displays the name of the user who has run the
upload SOD rules functionality.
The Last Run Status column displays the status of the upload SOD status
for last transaction. It can be SUCCESS/ERROR/FAILED.
The Comments column displays the comments generated on last upload/
remove SOD rules for given system.
The Last Run Type column displays the last action used by the user for
the corresponding system. It can be either Upload or Remove depending
on whether the last operation on system was Upload SOD Rules
/Remove SOD Rules respectively.

7.6.2 ADD SYSTEMS

Using the Add Systems button, you can add the systems for uploading the
SOD Rules.

The steps to add systems for uploading SOD Rules are as follows.

1.
2.

Click on Configuration tab.

In the left navigation pane, click the Utilities> Upload SOD Rules.
The Upload SOD Rules page opens.

Click on the Add Systems button.

The Add Systems page opens displaying the list under the column
headings Select, Id, Name, External System Id and Description.

Note: the Systems displayed are registered but not still added for
uploading SOD rules. The systems are created under
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Configuration> Application Center> system. The systems are
registered under Configuration> Registration.

et

X I Add Systems
« Registration

= Conneclors Save Cancel

v Application Center

« Applications I Name
- Systems

+ Uiilities | External System Id
= Import Master Data | Description

= Import Adapter
E
= FlatFile Configuration
Upload 50D Rules
= Upload SOD Rules Configuration
* AutoBatch Configuration
[m} 2004 JDE_GT811 JDE_TEST JDE_GT811
w Logs Manitar

This Page/ All Pages/ Reset
select(0)  1d Name # External System Id Description

» Application Log

] » [ <]0Faee 1 D]

Figure 7.17: Add Systems
5. Toadd a particular system, enter appropriate value in the
Name/ External System Id/Description text box and click Go.
-Or-
Click Go to add all the registered systems.
6. The Add System page displays the list of the systems under the column
headings Select, Id, Name, External System Id and Description.
7. Check the Select checkbox corresponding to the Id column.
8. Click on the Save button.

The screen displays message as, "Systems added successfully for SOD
Rule Upload" as shown in the following screenshot.

SR

X I Upload SOD Rules

« Regisiration
i —— Systems added successfully for SOD Rule Upload.
» Application Center [SEREEDE
~ Utilties Add Systems Import SOD Config XHiL Upload SOD Rules Remove SOD Rules
« Import Master Data
= Import Adapter | Name: | External System Ia
= FlatFile Configuration
Upload SOD Rules | Description | Rules Uploaded [“Seled— =l
= Upload S0D Rules Configuration | |_ast Run Date: o | 30D Config XML Uploaded [Fselec =
= AutoBatch Configuration | |
BT Last Run Status Select— = Last Run Type [~select- =
- Application Log Go
This Page/ All Pages/ Reset
View  Last Last Last
peied) i) Name 4 |BLETE Description 50D Successtully  Successtuy "€ SODFItEr o ipunpate Lastruney 2SIRUY Gomments Run
© System Id Rues  UpdaiedOn  Updatsagy Coniguration Status B
™ 2001 KOEL RAR_ORACLE | KOEL 0 Unatugn;zzma sapuser | View Uﬂuﬁﬁnﬁﬂﬂ sapuser  SUCCESS CLEAN
[~ 2003 NIKON NIKON NIKON
™ 2000 PEARSON PEARSON  PEARSON 0 ElE sapuser  View ppea™®sapuser  success CLEAN

Figure 7.18: Upload SOD Rules

7.6.3 IMPORT SOD CONFIG XML

Before importing SOD Config XML file, it is necessary to select the system.
The SOD Config.xml file is provided by the Greenlight technologies.

The steps to import SOD config XML are as follows.
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1. Click on Configuration tab.

2. In the left navigation pane, click the Utilities> Upload SOD Rules.
The Upload SOD Rules page opens.

3. Select appropriate system and click on the Import SOD Config XML
button.
The Import SOD Config XML screen opens.

4. Click on the Browse button and select the SOD Config XML file as

shown in the following screenshot.
Import SOD Config XML [

| import 50D Config XML

| 0D Confia XIL File (Local}:*  |C:\Documents and Settingsiusenl Browse..

Import

Figure 7.19: Import SOD Config XML
5. Click on the Import button.
The screen displays message as shown in the following screenshot.

Import SOD Config XML

| import 50D Config xmL

500 Config XML Import Complete.

| sop Config XML File (Local) :* Browse...

Import

Configuration Check Overall Status: \Warning (1}

System Mame Status Comments

Input Parameter mapping is naot
defined. S0 default value will be used:
[@IP#3, @IP#4, @IP#3, @IF#E, @IP#T,
@IP#8]

PEARSON_TE WARNING

Figure 7.20: Import SOD Config XML-Message

6. The Configuration Check Overall Status displays number of missing
configurations and successful uploads. For Example: there are five
records (3 Success + 2 Warnings) then, click on the number hyperlink.
The records are sorted out based on their status.

7. The System Name column displays the name of the system for which
SOD Config XML file is imported.

8. The Status column displays status of the import. For Example:
Warning/Successful.

9. The Comment column displays the comments given.
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7.6.4 UPLOADING SOD RULES

Before uploading SOD rules, it is necessary to select the system and import
SOD Config XML for the selected system.

The steps to upload SOD rules are as follows.

1. Click on Configuration tab.

2. In the left navigation pane, click the Utilities> Upload SOD Rules.
The Upload SOD Rules page opens.

3. Select appropriate system and click on the Upload SOD Rules button.
The screen displays message as shown in the following screenshot.

Informer Adapter Manager m
x I Upload SOD Rules
+ Registration
i View Defails
¥ Application Center Add Systems Import SOD Config XML \ Upload 50D Rules Remove SOD Rules
 Utiities
= Import Master Data. | name: | External System 10
- Import Adapter -
= FlatFile Configuration I Descrption I Rules Uploaded [~seleat- =
= Upload SOD Rules Configuration
= AutoBatch Configuration | LastRun status —Select— =l | LastRun Type: [~select— =]
 Logs Monitor =
o LG This Page/ All Pazes/Reset
View  Last Last
fﬁ'e" I HName 4 ;ml g  Descripon  SOD Lo oD ST LastRunDale LastRunBy 5ot Comments Losn
Rules  Updated On  Updated By pe
04-05-2013 . 04-08-2013 JDBC Connection is not
O 2087 10N 10N 108 0 06 2 SAPUSER  View 36 2 swPUSER FaLED  JOBCCH UPLOAD
[¥ 2007 |50D_SFTP_SYS 50D_SFTP_S |50D_SFTP_Sys -
Figure 7.21: Upload SOD Rules-Message
. . . . . .
4. Click on the View Details link to view the SOD Job Details.
. . . .
The View SOD Job Status displays details under the column headings
System, Status and Comments.
When the upload is completed, the screen displays message as shown in
the following screenshot.
P —T
% I Upload SOD Rules B
+ Registration
« Connectors SOD Rule Upload Complete. Please refresh the page. Last Job Details
¥ Application Center Add Systems Import SOD Config XML \ Upload SOD Rules Remove SOD Rules
 Utilities
« Import Master Data | Name: | External System Id
« Import Adapter
+ FistFile Configuration | Description | Rules Uploaded: [seleat— =
| LastRun Date o 150D Config XL Uploaded [Sete H
- Upload S0D Rules Confgurain | :
« AutoBatch Configuration LastRun Status; —Selec— =1 LastRun Type: [~sstea- |
 Logs Monitor =1
0 e This Pagef All Pages/ Reset
View Last Last
Sf'ed ] Name # E’“elg',?l " Deseription S0D ge‘ws()[}ﬁllel LastRunDate LastRun By ﬁ:"" Comments ';BS'R""
() Syt Rules  UpdatedOn  Updated By pe
04-05-2013 . 04-08-2013 JDBC Connection is not
203 1M 10N 10N o os 2 SAPUSER  View J+052 saPUSER  FaLED  JOBCC UPLOAD
¥ 2007 |50D_SFTP_SYS SOD_SFTP_S SOD_SFTP_Sys -

Figure 7.22: Upload SOD Rules
5. Click on the Last Job Details link to view the SOD Job Details.

The View SOD Job Status displays details under the column headings
System, Status and Comments.
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View Details

| view SOD Job Details

Close

FRI_SYS SUCCESS

Figure 7.23: View Details

Note: while uploading SOD rules if you click on the Cancel Job button, Then
Job is cancelled and the Last Run Status is displayed as CANCELLED
on the Upload SOD Rules page.

7.6.5 REMOVING SOD RULES

Before removing SOD rules, it is necessary to select the system for SOD
Config XML is imported and SOD rules are uploaded.

The steps to remove SOD rules are as follows.

1. Click on Configuration tab.

2. In the left navigation pane, click the Utilities> Upload SOD Rules.
The Upload SOD Rules page opens.

3. Select appropriate system and click on the Remove SOD Rules button.
The screen displays message as shown in the following screenshot.

T oo

X I Upload 50D Rules

B Remove SOD Rule is in-process. View Details

- Utilities

= Import Master Data I Name | External System Id:
+ Import Adapter
+ Flat Fila Configuration | Description: | Rules Uploaded [~selec =l
Upload SOD Rules | Last Run Date s} | soD connig XL Uploaded [-select— =l
* Upload SO Rules Cofguration | I
+ AutoBatch Configuration Last Run Status: [“Select =l Last Run Type: [“Select— |
 Logs Monitar Go
- Application L
g o This Page/ All Pazes/ Reset
04-05-2013 04-08-2013 JDBC Connection s nat
2097 1om 10N 10N 0 g SAPUSER | View oaario SAPUSER  |FALED o0 UPLOAD

[ |2007 |50D_SFTP_SYS 50D_SFTP_S \50D_SFTP_Sys |-

Figure 7.24: Upload SOD Rules
4. Click on the View Details link to view the SOD Job Details.

The View SOD Job Status displays details under the column headings
System, Status and Comments.

View Details
| view SOD Job Details

RAR_ORACLE IN-QUELE

Figure 7.25: View Details
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5. When the SOD rule removal is completed, the screen displays message as
shown in the following screenshot.

Informer Adapter Hanager
x I Upload SOD Rules
« Registration
I — 50D Rule Remove Complete. Please refresh the page. Last Job Details
e B Agd Systems | Import SOD Config XML Upload SOD Rules Remove S0D Rules
w Utilities
« Import Master Data | Name | External System 1t
o eyt | Description: | Rules Uploaded?: [Seleat =
« FlatFile Configuration
Upload 50D Rules | Last Run Date s | SOD Config XL Uploaded?: [Selea =1
* Upload SOD Rules Configuraion || 551 Ryn status: [Seeat =l | LastRun Type [Setet =l
= AutoBatch Configuration
 Lags Monitor Go
= Application Log This Pase/ All Pases/
View  Last Last View SOD
Sf‘m 1 Name # ?‘“{“"“m Description 50D Successfully Successiully Filter LastRun Date LastRun By éﬁR“" Comments #"’S‘R“"
@ LB Rules  Updated On  Updated By Configuration Bz pe
022013 022013
" 2000 |FRISYS FRI_SYS FRI_SYS 0 f";%‘zgm“ TestOA  |View ﬁj 1”0‘2‘2“1“ TestOA  SUCCESS CLEAN
™ 2010 | mcas MGAS MGAS m 1034_6%1;013 Test QA |View 1054—4%2;25013 Test @A  ERROR g:.:—suums toomany || oap
I |2008 | oORa115010 ORA115010 | ORA115010

Figure 7.26: Upload SOD Rules
6. Click on the Last Job Details link to view the SOD Job Details.

The View SOD Job Status displays details under the column headings
System, Status and Comments.

View Details &3

| view 50D Job Details

Close

Operation: Upload 50D Rules Overall Status: Failed (1)

System Name Status Comments
F1 FAILED egg\—ﬂﬂgde: table orview does not

Figure 7.27: View Details

Note: while removing SOD rules if you click on the Cancel Job button, then
Job is cancelled and the Last Run Status is displayed as CANCELLED
on the Upload SOD Rules page.

7.7 UPLOAD SOD RULE CONFIGURATION

Using the Upload SOD Rules Configuration feature, you can configure GRC
Application Connector for the Upload SOD Rules functionality.

The steps to set Upload SOD Rules Configuration are as follows.
1. Click on Configuration tab.

2. In the left navigation pane, click the Utilities> Upload SOD Rules
Configuration link.

The Upload SOD Rules Configuration page opens as shown in the
following screenshot.
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_—
Informer Adapter Manager Configuration

x I Upload SOD Rules Configuration

= Registration
= Connectors Save
» Application Center

v Utilities | GRE Application Connector ORAT15010 =
= Import Master Data
= Import Adapter
= FlatFile Configuration
* Upload SO0 Rules
= AutoBatch Configuration
+ Logs Monitor

= Application Log

Figure 7.28: Upload SOD Rules Configuration
3. In the GRC Application Connector dropdown list, select appropriate value.
4. Click on the Save button.

The screen displays message as shown in the following screenshot. The
information is saved in the AVM-RTA DS database.

e

® I Upload SOD Rules Configuration

= Regisiration
= Connectors Save
» Application Center
w Ulilities

| GRC Application Connector: [~Setect-
» |mpart Master Data
= |mport Adapter
= |mport CSV Data
= Properties
= Flat File Configuration
» Upload 30D Rules
» AutoBatch Configuration
= Application Configuration
= |mport Files
= Key Management
b AVM Import! Export Configuration
w Logs Monitor

= Application Log

Figure 7.29: Upload SOD Rules Configuration

Note: the GRC Application J]DBC Connector dropdown list is populated
with all active connectors defined in the RTA DS application. The
connectors are defined under Configuration> Connectors. . If you are
not using Upload SOD or Offline feature this configuration is not
required.

7.8 AUTOBATCH CONFIGURATION

The Autobatch Configuration screen displays the list of API's imported through
the Master Data File. In the master data file (local), you can set Auto_Enabled
field as Y/N. If the field is set as Y, all the API's displayed on the screen are
selected.

The steps for Autobatch Configuration are as follows:
1. Click on Configuration tab.
2. Click Utilities>Autobatch Configuration.
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The Autobatch Configuration page opens as shown in the following
screenshot.

—
x I AutoBatch Configuration
= Registration
= Connectors Save
» Application Center
w Utilities
APIId APl Name
= Import Master Data
« Import Adapter 2001 GETUSERACTMTY_R10
= =iy 2eE 2002 GETROLEDTLSFROMGRC_R1D
= Properties
- Fiat File Configuration 2005 GETROLEDTLSFROMGRG
* Upload SOD Rules 2007 GETERPDATETIME_R10
= Upload SOD Rules Configuration
2000 GETERPDATETIVE
0 I ETHEETT: 2011 GETUSERSYNC_R10
= Import Files =
- Key Management 2013 GETUSERSYNC
» AV Import/ Export Configuration 2915 GETUSERACTION_R10
w Logs Monitor
2017 GETUSERACTION
- lication Lt
RO o 2019 GETUSERPERMISSION_R10
2021 GETUSERPERMISSION
2023 GETROLESYNC_R10
2025 GETROLESYNC
2027 GETROLEACTION_R1D
2029 GETROLEACTION

) .
|
=

B & EE

EE REEEEEEE

Figure 7.30: AutoBatch Configuration

The screen displays API’s under the column headings API Id, API Name and
Select All columns.

Based on the configuration, in the master data file (local) the Select All
checkbox is checked /unchecked.

Click and select the API's which you want to display while scheduling a job.
Click Save.

The screen displays message as, “AutoBatch Configurations successfully
updated.”

Note: the API’s configured under Utilities>Autobatch Configuration page are
displayed on the Auto Batch Extraction >Job Scheduler page. To
access the page go to Adapter Manager>Auto Batch Extraction> Job
Scheduler-Create.

The Master data is imported under the Configuration>Utilities>Import
Master Data.

7.9 APPLICATION CONFIGURATION

The Application Configuration feature is used to set RTA DS and ResQ
applications URL.

The steps to configure application configuration are as follows:

1.
2.
3.

Click on Configuration tab.
Click Utilities>Application Configuration.

The Application Configuration page opens as shown in the following
screenshot.
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r ' Configuration

* I Application Configuration

= Registration

» Application Center

Import Adapter

Import C5V Data

Properties

Flat File Configuration

» Upload SOD Rules

= Upload SOD Rules Configuration
= AutoBatch Configuration

Application Configuration
= |mport Files

e

[+ Utiities™ S |RTADS URL* http /152 168 2.15-50700/PlatformAdapter/

Import Master Data | Res URL= http:/f192.165.2.15:50700/ResQAdpt/

Figure 7.31: Application Configuration

4. In the RTA DS URL text box, enter RTA DS application URL. For
http://192.168.2.15:50100/ xPlatformAdapter/

5. In the ResQ URL text box, enter ResQ application URL. For
http://192.168.2.15:50100/ ResQAdpt/

6. Click on Save to save the settings.

Example:

Example:

ACCESS VIOLANICON MAKNAGEWMEN]

Welcome sapuser [ Administrator ]

r ' Configuration

I Application Configuration

= Registration
= Connectors
» Application Center

L= | RTADS URL” nttp://192.168.2 15:50000/xFlatformAdapter/
Import Master Data | ResQ URL™ http /152 165 2 15:50000/ResQAdpY
Import Adapter
Flat File Configuration
Upload SOD Rules
Upload SOD Rules Ct
AutoBatch Configurati
= Import Files
= Key Management
« Logs Monitor

= Application Log

Save

Figure 7.32: Application Configuration
7.10 IMPORT FILES

The files imported here are used for flat file configuration.
The steps to import files are as follows:

1. Click on the Configuration tab> Utilities> Import Files.
2. The Import Files page opens.
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ALGLESS VIOLANON MAHAGEMEN]

Welcome sapuser [ GLT sapuser ]

= Flat File Configuration
» Upload SOD Rules
= Upload 0D Rules Cc
= AutoBatch Configurati
= Application Configurat
= Key Management

w Logs Monitor

= Application Log

Informer Adapter Manager Configuration
I Import Files
= Registration
= Connectors
» Application Center
w Utilities
File Name - *
= Import Master Data I Browse. ..
= Import Adapter | Upload Name : =

Import

Figure 7.33: Import Files

3. Click on the Browse button and select AuthData file in the File Name box.
This file resides in the Import Files>AuthData from the provided build.

4. In the Upload Name field, enter appropriate name.
5. Click on the Import button.

6. The file name and path is displayed as shown in the screen.

ACCESS VIOLAIION MAHAGEMEN]

Welcome sapuser [ GLT sapuser ]

Informer Adapter Manager Configuration

= Registration
= Connectors
- Application Center
= Applications
= Systems
w Ulilities
» Import Master Data
= Import Adapter
= Flat File Configuration
= Upload SOD Rules
» Upload SOD Rules Configuration
= AutoBatch Configuration
= Application Configuration
= Key Management
w Logs Monitor

= Application Log

*x I Import Files

| File Name : = Browse

| Upload Name : *

Import

Readme txt Path:/usr/sap/GLU/J03/|2ee/cluster/apps/sap.com/xPlatform/serviet_jsp/xPlatformAdapter/root/upload/Readme txt

Figure 7.34: Import Files

711 KEY MANAGEMENT

Using this functionality, you can select Key file and provide Key Name. The Key
name defined here is used while creating FLATFILE_TEXT connector of File-Key
Type in the Open SSH Key Name field.

1. Click on the Configuration tab> Utilities> Key Management.

2. The Key Management page opens.
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AGCEES VIOLAINON MAHAGEMEN |

Welcome sapuser [ GLT sapuser ]

Informer Adapter Manager Configuration

I Key Management

= Registration
= Connectors
» Application Center
w Utilities
= |mport Master Data
» Import Adapter | Key Name :*
= Flat File Configuration
* Upload SOD Rules Import
= Upload SOD Rules Cc
= AutoBatch Configurati
= Application Configurat
= |mport Files

w Logs Monitor

| Select Key File - = Browse...

= Application Log

Figure 7.35: Key Management

3. Click on the Browse button and select appropriate file in the Select Key File
box. The Private Key: SFTP and PGP Decryption key should be imported.

In the Key Name text box, enter appropriate name.

5. Click on Import button. The screen displays message as, “Key File updated
successfully.”

7.12 DEFINE IMPORT/EXPORT PROFILE

This feature allows defining set of Ariba Export/ AVM import files (along with
field definition) in AVM.

7121 SEARCH IMPORT EXPORT PROFILE

The search criterion helps to search a particular import export profile or find
all the existing profiles in one go.

The steps to search the import export profile are as follows.
1. Click the Configuration tab.

2. Click the AVM Import/Export Configuration >Define Import Export
Profiles.

The Import Export Profiles >Search page opens as shown in the below
screenshot.
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Informer ‘Adapter Manager Configuration

% || Import Export Profiles > Search

= Registration

= Connectors Create View Delete
» Application Center
» Utiliies

| Profile Name:
w AVM Import/ Export Configuration

= Define Realm Profile

Define Import/ Export Profiles Go|

~ Logs Monifor
= Application Log Select Profile Name #
(3 EUREALM

| Profile Type

() PARENT REALM

) USREALM

| Profile Description:
[~select ~] | Profile Sub Type: —Select- ~]
Profile Description Profile Typs Profile Sub Type
EU Realm Avriba File Format Type Ariba Export/AVM Import Type
PARENT REALM Avriba File Format Type Ariba Export/AVM Import Type
US Realm Ariba File Format Type Ariba Export/AVM Import Type

Figure 7.36: Import Export Profiles>Search
3. To view all the existing profiles, click Go.

-Or-

4. To view a particular Profile, enter appropriate value in the Profile
Name/ Profile Description. Select appropriate Profile Type/Profile Sub
Type field and click on Go.

5. Based on the selected criterion, details are displayed under the column
headings Select, Profile Name, Profile Description, Profile Type and

Profile Sub Type.

7.12.2 CREATE IMPORT EXPORT PROFILE- BY IMPORTING DATA

DICTIONARY

The steps to create the import export profile are as follows.
1. Click the Configuration tab.
2. Click the AVM Import/Export Configuration >Define Import Export

Profiles.

3. The Import Export Profiles >Search page opens.
4. Click on the Create button.
5. The Import Export Profiles >Create page opens as shown in the below

Adapter Manager Configuration

screenshot.
Informer
® I Import Export Profiles > Create
= Registration
= Connectors Neuxct Cancel
» Application Center
b Utilities

= Define Realm Profile

| Profile Name:*

~ AVM Import! Export Configuration

| Profile Description:

Define Import! Export Profiles | Profile Type:* [ Ariba File Format Type v
w Logs Monitor "
| Profile Sub Type: | Ariba Export/A\VIA Import Type v
- Application Log
| Import Data Dictionany:® Browse.
OR
| Copy Profile:” [-Setect- B2

Figure 7.37: Import Export Profiles >Create

6. In the Profile Name text box, enter appropriate name.

7. In the Profile Description text box, enter appropriate description.
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8. In the Profile Type dropdown, select appropriate value.
9. In the Profile Sub Type dropdown, select appropriate value.

10. Click on the Browse button and select appropriate Import Data
Dictionary. This file is provided in the package. For Example:
DataDictionary_EU.xls

Informer Adapter Manager Configuration

= I Import Export Profiles > Create

= Registration
= Connectors Next Cancel
» Application Center
» Utilities

S S | Profile Name: EU Realm 1
+ Define Realm Profile | Profile Description: EU Realim 1
| Profile Type:* | Ariba File Format Typs ]
e MO"fth | Profile Sub Type:* | Ariba Export/A\VM Import Type (]
- Aomieaentes | | Import Data Dictionary:* \Desktop\DataDictionary_EUxls|  Browse..
OR
| Copy Profile: [~Selec- =

Figure 7.38: Import Export Profiles >Create
11. Click on the Next button.

12. The Import Export Profiles > Select Files screen opens.
|I Import Export Profiles > Select Files

Mext Cancel

| Profile Name: EU Realm 1

| Profile Description: EU Realm 1

| Profile Type: Ariba File Format Type

| Profile Sub Type: Ariba Export!AYM Import Type

| Select Tasks/ Files:

PurchaseCrderCancelExport

D CancelPurchOrdHeader.csv
Export Tax Codes

[ TaxCodeHeadsr csv
[ TaxCodeDetails.csv
Export Change Purchase Order

D ChangePurchOrdHeaderDet csv
[ changePurchrdLineDet.csv
[[] changePurchOrdAcctDet csv
[] changePurchOrdSchdiDet.csv
[] changePurchOrdDelAcct.csv
D ChangePurchCrdDelltems.csv
[] changePurchOrdLineText csv

Figure 7.39: Import Export Profiles >Select Files
13. Check the appropriate tasks/files check box.
14. Click on the Next button.

Greenlight Technologies, Inc. Page 63 of 123



Geentiont

AVM- RTA Design Studio User Guide v2.0SP07

15. Import Export Profiles > View Files And Fields screen opens as shown
in the below screenshot.

I Import Export Profiles = View Files And Fields

Save Cancel

| Profile Name: EU Realm 1
| Profile Description: EU Reaim 1
| Profile Type: Ariba File Fermat Type
| Profile Sub Type: Ariba Export/AVM Import Type
| Profile Files:
CancelPurchOrdHeader csv
Field Name Field Description Field Data Type Field Length Field Required? Field Allow Null?

Defines the unigue Purchase Order |D of every version for which
ERPPONumber it shows a status. This value must match a EBELN field defined i String 50 Y Y
CancelPurchOrdHeader.csv,
This is the a supplemental version number of the original order.
Ariba Buyer implements cancel orders by sending an updated
order to the supplier, as a revision of the original order. The order

Versionhumber number remains the same, but there is a supplemental version Integer ¥ ¥
number This value must match a VERSION field defined in
CancelPurchOrdHeader.csv,
Defines the unique Purchase Order |D with latest version
UnigueName number. This value must match a ERPCRDERID field defined in | String 50 Y N
CancelPurchOrdHeader.csv,
cus_FxternalComments String 1000 N Y
cus_SendExternalComments Boolean N ¥
ERPRequisitionlD The requisition ID of this document in the ERP. String 50 Y

Figure 7.40: Import Export Profiles >View Files And Fields

16. The Import Export Profiles > View Files And Fields screen displays
detail information about Profile Files under selected .CSV file under
columns Field Name, Field Description, Field Data Type, Field Length,
Field Required? Field Allow Null?

17. Click on Save. The screen displays message as, “Profile created
successfully.”

18. The newly created profile is listed on the Import Export Profiles >Search
screen.

7.12.3 CREATE IMPORT EXPORT PROFILE- BY COPY PROFILE

The steps to create the import export profile are as follows.
1. Click the Configuration tab.

2. Click the AVM Import/Export Configuration >Define Import Export
Profiles.

3. The Import Export Profiles >Search page opens.
4. Click on the Create button.

5. The Import Export Profiles >Create page opens as shown in the below
screenshot.
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r ' Configuration

* I Import Export Profiles > Create
= Registration
o
» Application Center
- LTiEEs | Profile Name:*
~ AVM Import/ Export Configuration
+ Define Realm Profile | Profile Description:
Define Import! Export Profiles | Profile Type:® |A|1'ba File Format Type
w Logs Monitor N
| Profile Sub Type: [Ariba Export/Avi Import Type
- Application Log
| Import Data Dictionary:™ Browse._
OR
| Copy Profile:* | -Select-

Figure 7.41: Import Export Profiles >Create
In the Profile Name text box, enter appropriate name.
In the Profile Description text box, enter appropriate description.
In the Profile Type dropdown, select appropriate value.

0 2 N

In the Profile Sub Type dropdown, select appropriate value.

10. Click on the Browse button and select appropriate Import Data
Dictionary.
-Or-

11. In the Copy Profile dropdown select appropriate profile. This dropdown
is populated with previously created profiles.

12. Click on the Next button.

The Import Export Profiles > View Files And Fields screen opens as

shown in the below screenshot.
Import Export Profiles > View Files And Fields

e
| Profile Name: SFSF

| Profile Description: SFSF

| Profile Type: Ariba File Format Type

| Profile Sub Type: Ariba Export/A\VM Import Type
| Profile Files:

Field Name Field Description Field Data Type Field Length ‘ Field Required? Field Allow Null?
StagedGroupResponsibles. PurchasingUnit The unigue internal identifier of a purchasing unit. Sfring 100 ‘

UnigueName The unigue internal identifier of a Group Sfring 258 ‘Y N
StagedGroupResponsibles UnigueName The unigue internal identifier of a user. Siring 100 ‘Y

StagedGroupResponsibies PasswordAdapter The name of the password adapter for the user specified in the String 100 ‘Y

User_UnigueName field.

Field Name Field Description Field Data Type |Field Length  Field Required? rﬂﬁ'g Allow
TimeCreated Date N A
The full name of the user. This is the name that appears in the . N
Name User intertace. NMultiLingual String Y Y
The user email address, which is used for sending notfification
EmailAddress messages. The value must be a simple email address, such as | String 255 Y Y

Figure 7.42: Import Export Profiles >View Files And Fields

Greenlight Technologies, Inc. Page 65 of 123



Geentiont

AVM- RTA Design Studio User Guide v2.0SP07

13. The Import Export Profiles > View Files And Fields screen displays
detail information about Profile Files under selected .CSV file under
columns Field Name, Field Description, Field Data Type, Field Length,
Field Required? Field Allow Null?

14. Click on Save. The screen displays message as, “Profile created
successfully.”

15. The newly created profile is listed on the Import Export Profiles > Search
screen.

7.12.4 VIEW IMPORT EXPORT PROFILE

The steps to view the import export profile are as follows.
1. Click the Configuration tab.

2. Click the AVM Import/Export Configuration >Define Import Export
Profiles.

The Import Export Profiles >Search page opens.
Select appropriate profile.
Click on the View button.

The Import Export Profiles > View Files And Fields screen opens
displaying detail information about selected profile as shown in the
below screenshot.

ISANRS LN

Import Export Profiles = View Files And Fields

Save Cancel

| Profile Name: SFSF

| Profile Description: SFSF

| Profile Type Ariba File Format Type

| Profile Sub Type: Ariba Export/A\VM Impart Type

| Profile Files:
ConsolidatedGroupExport.csv
Field Name Field Description Field Data Type Field Length Field Required? Field Allow Null?
StagedGroupResponsibles. PurchasingUnit The unique internal identifier of a purchasing unit. String 100
UnigueName The unigue internal identifier of a Group Siring 258 Y N
StagedGroupResponsibles UnigueName The unigue internal identifier of a user. Siring 100 Y

Tne name of the password adapter for e user specifiedintne gy 100 v

StagedGroupResponsibles PasswordAdapter User LniqueName field

DeactivatedSharedUserExport.csv
Field Name Field Description Field DataType  Field Length  Field Required? Fieid Alow
TimeCreated Date N N
The full name of the user. This is the name that appears in the . -
Name user interface. MultiLingual String Y Y
The user email address, which is used for sending nofification
EmailAddress messages. The value must be a simple email address, such as | String 285 Y Y

Figure 7.43: Import Export Profiles >View Files And Fields
7.12.5 DELETE IMPORT EXPORT PROFILE

The steps to delete the import export profile are as follows.
1. Click the Configuration tab.
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2. Click the AVM Import/Export Configuration >Define Import Export
Profiles.

3. The Import Export Profiles >Search page opens.

4. Select appropriate profile.

5. (Click on the Delete button.

6. The screen prompts with below confirmation message.

Message from webpage &I

| Do you want to delete the selected profile?

OK ] l Cancel

Figure 7.44: Message
7. Click on OK.

8. The Import Export Profiles >Search displays message as, “Profiles
deleted successfully.”

7.13 DEFINE REALM PROFILE

This feature allows define Ariba System realms and associate the Import/ Export
profile with the realm.

7.13.1 SEARCH REALM PROFILE

The search criterion helps to search a particular realm profile or find all the
realm profiles in one go.

The steps to search the realm profile are as follows.

1. Click the Configuration tab.

2. Click the AVM Import/Export Configuration >Define Realm Profile.
The Realm Profile >Search page opens as shown in the below screenshot.
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I Realm Profile > Search

Create | Delete | Dpen|

| Name:

| Description:

Go |
Select Id Name ¢ Description
e 15 ARIBA Ariba

[ < Jeage ld  On

Figure 7.45: Message
To view all the existing realm profile, click Go.
-Or-
To view a particular Realm Profile, enter appropriate value in the Name
and Description and click on Go.

Based on the selected criterion, details are displayed under the column
headings Select, Id, Name and Description.

7.13.2 CREATE REALM PROFILE

The steps to create the realm profile are as follows.

1.

AN IR N

Click the Configuration tab.

Click the AVM Import/Export Configuration >Define Realm Profile.
The Realm Profile >Search page opens.

Click on Create.

The Realm Profile >Create page opens.

Realm Profile > Create

Save Cancel

| Name:*

| Description

| Realm Profile* —Select—

v ©

Figure 7.46: Realm Profile > Create
In the Name text box, enter appropriate name of the realm.

In the Description text box, enter appropriate description about the
realm.
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8. Select the appropriate Realm Profile in the dropdown and enter
appropriate values in the corresponding text boxes.
9. Click on Save.

10. The Realm Profile >Search page displays message as, “<Realm Name>:
Realm Profile created successfully.

7.13.3 VIEW REALM PROFILE

The steps to view the realm profile are as follows.

Click the Configuration tab.

Click the AVM Import/Export Configuration >Define Realm Profile.
The Realm Profile > Search page opens.

Select appropriate profile.

Click on the Open button.

A

The Realm Profile > Open screen opens displaying details of the realm
such as Id, Name, Description and Realm Profile as shown in the below

screenshot.
Realm Profile = Open
Save Cancel
|1d 5
| Name:* ARIBA
| Description: Ariba
| Realm Profile* EU REALM EU REALM [EUREALM
US REALM US REALM IUS REALM
PARENT REALM PARENT REALM IPARENT REALM

Figure 7.47: Realm Profile > Open

7.13.4 DELETE REALM PROFILE

The steps to view the realm profile are as follows.

Click the Configuration tab.

Click the AVM Import/Export Configuration >Define Realm Profile.
The Realm Profile > Search page opens.

Select appropriate profile.

Click on the Delete button.

The screen prompts with below confirmation message.

Message from webpage ﬁ

AN S

:] Do you want to delete the selected realm profile?

Ok l I Cancel

Figure 7.48: Confirmation Message
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7. Click on OK.

8. The Realm Profile > Search page displays message as, “<Name>: Realm
Profile deleted successfully.”
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8 PROGRAM WORKBENCH

Program Workbench includes the definitions and configurations of the Standard

Adapters provided. This section covers Program Definitions and Program
configurations.

8.1 PROGRAM DEFINITION

Under the Program Definition, the Program Definitions and Program
Configurations are clubbed. These are associated with the Standard Adapters.

8.1.1 SEARCH PROGRAM DEFINITION

The search criterion helps to find program definition. The search criterion
helps you to search a particular program definition or find all the existing
program definition in one go.

The steps to search the program definition are as follows.
1. Click the Adapter Manager tab.
2. In the left navigation menu, click the Program Workbench>Program

Definition.
The Program Definition>Search page opens as shown in the screenshot
below.
% | Program Definition > Search
~ Program
= Program Configuration
~ Standard Adapters | Name
D EEE | Description:
» Custom Adapters
v Auto Batch Extraction lere Application : ~Select- 4
- Job-API Search | Program Type - _Select— v
= Job Scheduler
Go
Select Name / Description GRC Application Program Type
© | ADDROLE_JDBC10 Procedure to Add Role CcupP STOREDPROCEDURE
C | CHANGEROLE_JDBC10 Procedure to Change Role CcupP STOREDPROCEDURE
& | CHANGEUSER_JDBC10 Procedure to change user CuP STOREDPROCEDURE
© | CREATEUSER_JDBC10 Procedure to create user. CUP STOREDPROCEDURE
© | CUP_AUTHENTICATE_JDBC10 Procedure to Authenticate. RAR STOREDFUNCTION
| CUP_GEMERATE_PASSWORD_JDBC10 Procedure to Generate Password. RAR STOREDPROCEDURE

Figure 8.1: Program Definition>Search
3. To view all the existing program definition, click Go.
-Or-
To view a particular Program Definition, enter the parameter value in
the Name/Description/GRC Application/Program Type field and click
on Go.

The screen displays records under the column headings Select, Name,
Description, GRC Application and Program Type.
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8.1.2 CREATE PROGRAM DEFINITION

The steps to create program definition are as follows.

1.
2.

9.

Click the Adapter Manager tab.

In the left navigation menu, click the Program Workbench>Program
Definition.

The Program Definition>Search page opens.
Click Create.

The Program Definition>Create page opens as shown in the following
screenshot.

Informer Adapler Manager Configuration

X I Program Definition > Create

w Program Workbench

Program Definition Save Cancel

* Program Configuration
~ Standard Adapters | Name=* Report review

= search
| Description review

b Custom Adapters

» Auto Batch Extraction | connection Type: JDBC b
| GRC Application = RAR i
| Program Type: STOREDPROCEDURE b
| Program * INSTR (PERMISSION, |, 1, 1) + 2, (NSTR |~
(PERMISSION, ~', 1, 1) - INSTR
(PERMISSION, ', 1, 1) - 2)) END "FIELD". | ¥
| status: Active v
| Program status: DRAFT 3

| Program Detail 1 null

| Program Detail 2: null

Figure 8.2: Program Definition>Create
In the Name text box, enter appropriate name of the program definition.
In the Description text box, enter appropriate description.
In the Connection Type dropdown list, select appropriate connection
type. For Example: JDBC.
In the GRC Application dropdown list, select appropriate value. For
Example: RAR.

Note: to create report under informer tab, select the GRC Application
type as REPORT.

In the Program Type dropdown list, select appropriate value. For
Example: STOREPROCEDURE.

Note: to create report under informer tab, select the Program Type as
QUERY.

In the Status dropdown, list as active.

10. In the Program Detail 1 text box, enter appropriate details.

11. In the Program Detail 2 text box, enter appropriate details.

12. Click Save to save the record.

8.1.3 VIEW/MODIFY PROGRAM DEFINITION

The steps to view/modify the program definition are as follows.
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b

6.

On the Program Definition>Search page, click the select column
corresponding to the program definition name, which you want to
view/modify.

Click on the Open button.

The Program Definition >Open page opens as shown in the screenshot
below.

Informer Adapter Manager Configuration

X I Program Definition > Open

w Program VWorkbench

Program Definition Back

= Program Coenfiguration
v Standard Adapters | Hame:* CUP_AUTHENTICATE_JDBC10
s Search

|Description - Procedure to Authenticate.
» Custom Adapters

¥ Auto Batch Extraction | connection Type

|GF‘.C Application
|Program Type

| Program: * Glt_Ora_Cuprta.Authenticate(?.7.7.7}

|Status
|Prugram Status
|Prngram Detail 1 null

| Pragram Detail 2 null

Figure 8.3: Program Definition>Open
The Name field is not editable.
Edit the Description as required.

Edit the Connection Type, Program Type, Program and Status as
required.

Note: these fields are editable for the Custom Programs only. The
Standard Programs are non-editable.

Click Save to save and update the changes.

8.2 PROGRAM CONFIGURATION

The Program Configuration Page has Fields (Output Columns) and Parameters
(Where Criteria columns) to be configured for a particular program definition.

The Custom Programs are editable. The Standard Programs and Program
Configurations are non - editable.

8.21 SEARCH PROGRAM CONFIGURATION

The search criterion helps to find program configuration. The search criterion
helps you to search a particular program configuration or find all the existing
program configuration in one go.

The steps to search the program configuration are as follows.

1.

Click the Adapter Manager tab.
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2. In the left navigation menu, click the Program Workbench>Program
Configuration.

The Program Configuration>Search page opens as shown in the
following screenshot.

Informer Adapter Manager Configuration

X I Program Configuration > Search
« Program

* Program Definition Configure Test Program
Program Configuration

~ Standard Adapters

| Name: | Adapter Name -
* Search

| Description: | Program Category - Select— v
» Custom Adapters

| Program Type

+ Auto Batch Extraction ~Select- ¥ | GR Application - ~Select- ¥

= Job-API Search =

= Job Scheduler
Select Name Description GRC Application Program Type Adapter Name  Program Categary,
© | ADDROLE_JDBC10 Procedure to Add Role cup STOREDPROCEDURE JDBCCUP_R10 STANDARD
© | CHANGEROLE_JDBG10 Procedure to Change Role cup STOREDPROCEDURE JDBCCUP_R10 STANDARD
© | CHANGEUSER_JDBC10 Procedure to change user cup STOREDPROCEDURE JDBCCUP_R10 STANDARD
© | CREATEUSER JDBC10 Procedure to create user. cup STOREDPROCEDURE JDBCCUP_R10 STANDARD
© | CUP_AUTHENTICATE JDBC10 Procedure to Authenticate RAR STOREDFUNCTION | JDBC_RTA10 | STANDARD
© | CUP_GENERATE_PASSWORD_JDBC10 Procedure to Generate Password. RAR STOREDPROCEDURE JDBC_RTA10  STANDARD

Figure 8.4: Program Configuration>Search
3. To view all the existing Program Configuration, click Go.
-Or-
To view a particular Program Configuration, enter the parameter value
in the Name/Description/Adapter Name/Program Type/Program
Category /GRC Application field and click on Go.
4. The screen displays under the column headings Select, Name,

Description, GRC Application/Program Type, Adapter Name and
Program Category.

8.2.2 PROGRAM CONFIGURATION

There are different programs such as SQL queries; stored procedures, APIs,
java programs etc. All the programs require certain input parameters. These
parameters are full or incremental sync, from user Id to user Id, from Date, to
Date etc.

1. On the Program Configuration >Search page, click and select the
program configuration which you wants to modify.

2. Click on Configure.

3. The Program Configuration>Parameter(s) screen appears as shown in
the screenshot below.
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Informer Adapler Manager ‘Configuration

x I Program Configuration > Parameter(s)

w Program

= Program Definition Next Cancel

Program Configuration
v Standard Adapters | Name - GL_ACCOUNT_POSTINGS
* Search | Description - GL_ACCOUNT_POSTINGS
¥ Custom Adapters | seript Type - QUERY
¥ Auto Batch Extraction | Program - SELECT LACGOUNT AS "ACCOUNT" L CURRENCY_CD AS 'CU . @
Add
Select Name Description Data Type Operator Low Value High Value Parameter Type|

Figure 8.5: Program Configuration>Parameter(s)

4. Click eimage to view the program.
The Program screen opens as shown in the following screenshot.

| Program : SELECT LACCOUNT AS "ACCOUNT"L.CURRENCY_CD
AS "CURRENCY_CD".L.MONETARY_AMOUNT
AS "TOTAL_AMOUNT" L MONETARY_AMOUNT
AS "ABSOLUTE_TOTAL_AMOUNT" L.FOREIGN_CURRENCY
AS "FOREIGN_CURRENCY",L.FOREIGN_AMOUNT AS "TOTAL_FOREIGN_AMOUNT"
FROM PS_JRNL_LM L WHERE L ACCOUNT ='206100"' AND L.CURRENCY_CD ='USD'

Figure 8.6: Program

5. To add the parameter, on the Program Configuration>Parameter(s)
screen, click Add button.

The Parameter screen opens as shown in the following screenshot.

Parameter
| name:* System_ID

| Description: System_ID

| Data Type: * String b

| Parameter Type: N 3

| cperator: - Equals 9

| Refby:

| value - JD_Dv811

Figure 8.7: Parameter
6. Inthe Name and Description text box, enter appropriate details.

7. Select Data Type, Parameter Type, and Operator from the dropdown list.

Note: if the program doesn’t have any input parameter in query, you can
add input parameters using Add Parameter. Select parameter type
as In. These input parameters are displayed under
Informer>Reports tab.

8. Enter appropriate Value and click Save.

The Program Configuration>Parameter(s) screen displays parameter as
shown in the following screenshot.
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Informer Auapler Manager Configuration

% | Program Configuration > Parameter(s)

~ Program

* Program Definition Next Cancel
Program Configuration

v Standard Adapters | Name - GL_ACCOUNT_POSTINGS
* Search | Description - GL_ACCOUNT_POSTINGS

¥ Custom Adapters. | Script Type QUERY
» Auto Batch Extraction | Program -

SELECT L ACCOUNT AS "ACCOUNT",L CURRENCY_CDAS "CU

Select Name Description Data Type
O SYSTEM_ID System_ID String

Q

Operator Low Value
JD_DVv811

Add Open Remove

High Value Parameter Type|
N

Figure 8.8: Program Configuration>Parameter(s)

9. Click on Next, to go to next step of Program Configuration.

10. The Name, Description, Script Type, and Program field are populated

with defined values.

Note: the program configuration is done for the Custom Adapters only.
In case of the Custom Adapters, add and remove buttons are
available on the screen to add or remove the fields from the

program.

11. To add the field, click on Add.

The field screen appears as shown in the screenshot below.

Fields

Save Cancel

| Wame: *
| Description:

| Data Type: * Number w
| Alias:

Figure 8.9: Fields

12. In the Name textbox, enter appropriate name of the field.

13. In the Description box, enter appropriate description of the field.

14. In the Data Type dropdown list, select appropriate data type.

15. In the Alias text box, enter appropriate value.

16. Click on Save to save the newly defined field record.

Note: after configuring the Program, it is available for adding to on the
API Field mapping page for assigning of programs to the APIs.

8.2.3 TEST PROGRAMS

Test program allows users to test the programs imported through adapter
import for standard adapters. The adapters are imported through
Configuration->Utilities>Import Adapter. Every imported standard

adapter has a userSync, userAction, and testObjects programs.

The steps to test the program configuration are as follows.
1. Click the Adapter Manager tab.
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2. Click Program Workbench> Program Configuration in the left menu bar.
The Program Configuration>Search screen opens.

3. Click and Select the program which you want to test and click on Test
Configuration.

The Program Configuration>Test Configuration screen opens as shown
in the following screenshot.

Informer AdaptevManager Configuration

% ] Program Configuration > Test Program
~ Program Workbench

o FEE T TestProgram || Save || Cancel
Program Configuratior
| Frogram Name GET_ACTIONLOG_IDBC10 | Description Pracedure to get Action Log
< SR ETEE | Connection Type: JpBC | Program Type STOREDPROCEDURE
- Search
| Connector | Program Details GLT_ORA_RARRTA get_user_alert?,22,22,222 .. @
¥ Custom Adapters
b Auto Batch Extraction Select Connecior | Limitte 100 4
| Action_Leg_Cur  (cursor) - | startDate (STRING ) 20100203
| starTime (STRING ) | endDate ( String ) 20110310
| endTime ( String ) | syskey (STRING) 202

4

userid action logDate lagTime terminal sysKey

Figure 8.10: Program Configuration>Test Program

4. The Program Name, Connection type, Description, Program type,
Program Details fields is populated with predefined values.

5. Click on Select Connector button.

The Connector screen opens as shown in the following screenshot.

Connector
Select Cancel
Select Connector Description
) | INFOLEASECONN INFOLEASECONN
() |JDBC_ARIBA Connector For ARIBA
¢ |HYPERION_FDM_SY¥S_11 | Coonector for HYP FOM Sys 11
() | FDM_SQOLSERVER Connector for FOM
) |BAAN Conn for BAAN
O BAAN_DEM Connector For BAAN_DEM
() | ORACLE Connector For Oracle
() |FDM_ORACLE FOM ORACLE

Figure 8.11: Connector
6. Select appropriate connector and click on Select button.

7. Provide appropriate values to the program parameters such as connector
Ids.

8. Click on the Test Program button.

This executes a particular program against the selected connector.
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9. 1If the program is configured appropriately the results are displayed on
the lower portion of the Program Configuration> Test Configuration
screen.
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9 STANDARD ADAPTERS

The Standard Adapters are the delivered programs and API field mapped units
that are imported through Import Adapter.

1.

Import Adapter (Configuration Tab -> Utilities): The screen prompts for
the Adapter Name and the Application Name and asks for the XML file to be
imported. The XML File once imported will create the programs in the
Program Definition and Configuration screens.

The Adapter is created in the Standard Adapters and then the System and
Connector are mapped to it.

9.1 SEARCH STANDARD ADAPTERS

Use a search criterion to find standard adapters. The search criterion helps you to
search particular standard adapters or find all the existing program standard
adapters in one go.

The steps to search the standard adapters are as follows.

1.
2.

Click the Adapter Manager tab.
In the left navigation menu, click the Standard Adapters.

The Standard Adapters >Search page opens as shown in the screenshot
below.

Informer Anams-r Manager Configuration

x I Standard Adapters > Search

¥ Program Workbench

w Standard Adapters Open Delete

» Custom Adapters | Adapter Name

¥ Auto Batch Extraction
| Adapter Description:

| GRC Application [~select-

(ENQEY

| xppiication Name : |,ge|m,
Go
Select Adapter Name # Adapter Description GRC Application
el CUP_ORACLE_11510.2 CUP Oracle Apps Version 11.5.10.2 CupP
| JDA_RTA10_RAR RAR Adapter For DLA JDA RAR

| ORACLE_11510_1 Oracle Apps Version 11.5.10.2 RAR

Application
FRI_AFP
IDA_APPL
FRI_APP

Figure 9.1: Standard Adapters>Search
To view all the existing Standard Adapters, click Go.
-Or-
To view a particular Standard Adapters, enter the parameter value in the

Adapter Name/Adapter Description/GRC Application/Application Name
and click on Go.

The screen displays records under the column headings Select, Adapter
Name, Adapter Description, GRC Application and Application.
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9.2 DELETE STANDARD ADAPTERS

The steps to delete the standard adapters are as follows.

1. On the Standard Adapters>Search page, click the select column
corresponding to the adapter name, which you want to delete.

2. Click on the Delete button.
The following message appears on the screen.

Message from web x|

\‘?I’) You are abouk to delete Adapter . Do you wank to continue?

(04 Zancel

Figure 9.2: Message

3. Click on the OK button. The screen displays message as, "Adapter data
deleted successfully.

Informer Adapter Manager Configuration
x I Standard Adapters > Search
¥ Program Workbench
+ Standard Adapters Adapter data deleted successfully.
» Custom Adapters
b Auto Batch Extraction | Adapter Name:
| Adapter Description
| GRC Application [~Selea- 5|
| Application Name [Seleat- =l
Go
Select Adapter Name # Adapter Description GRC Application
| CUP_DRACLE_115.102 CUP Oracle Apps Version 11.5.10.2 cup
| JDA_RTAI0_RAR RAR Adapter For DLA JDA RAR

Application
FRLAPP

JDA_APPL

Figure 9.3: Standard Adapters> Search

Note: If the adapter is mapped, to the system and job is IN-PROCESS or
SCHEDULED state, you cannot delete the adapter in that case the
system displays the message as shown in the Fig 9.4.

. Standard Adapters > Search

[There are jobs scheduled for the systems mapped in the adapter,please cancel those jobs to delete the selected Adapter.

Open Delete

| Adapter Name

| Adapter Description:

| GRC Application | —~Selert- j
| Application Mame I —Select- j
8o}

Figure 9.4: Standard Adapters> Search

9.3 VIEW/MODIFY STANDARD ADAPTERS

For a standard adapter you can modify its association with the system. You can
remove the system-connector or add a system connector to it.

The steps to view/modify the standard adapters are as follows.
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1. On the Standard Adapters>Search page, click the select column
corresponding to the adapter name, which you want to view/modify.

2. Click on the Open button.

The Standard Adapters >Open page opens as shown in the screenshot
following screenshot.

X I Standard Adapters > Open

» Progiam

Standard Adapters Add/Remove System m APl Mapping ||| Sawe |
» Custom Adapters
» Auto Batch Extraction | Adapter Name: JDBC_RTATD
| Adapter Description: Adapter For Oracle JDBC
| Application Name: ORACLE APPLICATION
| GRS Application RAR
APIs Mapped

Add System

O 2208 GETUSERORG_R10FORSQD GET_USER_ORG_IDBC10 STOREDPROCEDURE 0
O 2210 GETROLEORG_R10FORSCD GET_ROLE_ORG_JDBC10 STOREDPROCEDURE 0
O 2212 GETACTIONINFO_R10FORSOD GET_ACTION_INFO_JDBC10 STOREDPROCEDURE 0
O 2214 GETPERMISSIONTEXT_R10FORSOD GET_PERMISSION_TEXT_JDBC10 STOREDPROCEDURE 0
O 2216 GETACTIONPERMISSIONS_R10FORSOD| GET_ACTION_PERMISSIONS_JDBC10 STOREDPROCEDURE 0
O 2218 GETUSERROLES_R10FORSOD GET_USER_RESP_JDBC10 STOREDPROCEDURE 0
— 3990 RETRAI ESFNRIISER B1NFNRSNN ~FET DESD FNR ISFR INRCN STARFNBRACEN IBE n

Figure 9.5: Standard Adapters>Open

3. The Adapter Name, Adapter Description, Application Name, GRC
Application are not- editable and are populated with the defined values.

4. To Add/Remove a system, click and select the column corresponding to API
name and click on the Add/Remove System.

The Standard Adapters> Add/Remove System screen opens as shown in the
screenshot below.

|4 ' [Ty — r

X I Standard Adapters > Add/Remove System

» Program Workbench

o o ) 5o [ Coen |

¥ Custom Adapters | Application Name: SAP_QA

¥ Auto Batch Extraction | Adapter Hame: JDBC_RTA10
| Program Name GET_ROLERANGES_JDBC10
| API Name GETROLERANGES_R10FORSOD

Add System || Remove System |

O |RTA2 RTAZ
O |NEW SYS RTAZ
© | PARAMETER_TEST SAPJCO

Figure 9.6: Standard Adapters>Add/Remove System
5. Toadd a system, click on Add System.

The System-Connector screen opens as shown in the screenshot below.

System-Connector

‘

&

CASHPOOLER_SYS CASHPOOLER v |

&

CP_SYS CP_SYS v|
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Figure 9.7: System-Connector
6. Click and select the system, which you want to add and click on Select.
7. Click Save to add the system.

The screen displays message,”<Adapter Name>: Details saved
successfully.”

8. To see the Program output fields and the Program parameters to the external
API, go to Standard Adapters> Open screen.

Informer Mamev Manager Configuration

X I Standard Adapters > Open

¥ Program Workbench

~ Standard Adapters Back Add/Remove System APItapping || Saue

¥ Custom Adapters | Adapter Name JDBC_RTA10

¥ Auto Batch Extraction
| Adapter Description Adapter For Oracle JDBC
| Application Name SAP_QA
| GRC Application RAR

APIs Mapped Add System

AF Select apilg AP Name Program Narme Program Type System Count
O 2765 | GETROLERANGES_R1OFORSOD GET_ROLERANGES_JDBC10 STOREDPROCEDURE 3
O 2787 | GETPROFILERANGES_RIOFORSOD | GET_PROFILERANGES_IDBC10 STOREDPROCEDURE 3
O 2789 GETPROFILESYNC_R10FORSOD GET_PROFILESYNC_JDBC10 STOREDPROCEDURE 3
(] 2785 GETPROFILEPERMISSION_R10FORSOD| GET_PROFILEPERMISSION_JDBC10 STOREDPROCEDURE 3
O 2783 | GETPROFILEACTION_R10FORSOD GET_PROFILEACTION_JDBC10 STOREDPROCEDURE 3
O 2781 | GETPERMISSIONGROUP_R10FORSOD | GET_PERMISSIONGROUP_JDBC10 STOREDPROCEDURE 3
= 2779 | AFTBERMISSIANE TTT R1IEARSAN | RET PERMISSINNEIR MTEYT INAr1n STARENPRACENI IBE B

Figure 9.8: Standard Adapters>Open
9. Click System Count Link to view mapped System-Connector.
10. Select an appropriate API. Click on the API Mapping.

The Standard Adapters>API Mapping screen opens as shown in the
screenshot below. You can additional fields /parameters.

Note: RTA DS facilitates users to add additional fields/parameters than
existing, by using LH image. Using this Additional Input/output
Configuration, any Additional input parameters from SAP GRC can

be mapped to a Program parameter and any Program field can be sent
to SAP GRC as an additional output field.

Informer Adapter Manager Configuration

x I Standard Adapters > APl Mapping

¥ Program Waorkbench

w Standard Adapters Save Back Cancel

¥ Custom Adapters | API Hame GETACTIONINFO_R10FORSOD | Program Name SAP_ACTION_INFO
» Auto Batch Extraction | Application Name SAP_QA | Program Type SAP

| Adapter Name SAPJCOADAPTER | Pragram ZRFC_GLT_BPC_TASK DEsc @

Assign Parameters

API Parameters Legacy Application Paramster Information Delete Option
actionFrom NULL null
angCode P_LANGU null

Assign Fields

Delete

API Fisld Legacy Application Fisld Field Alias/Constant Information Option
action Action null
actionText Action_Text null

g

Figure 9.9: API Mapping
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11. Under Assign Parameters, click L image to add additional parameters to
APTI’s.

The Legacy Application Parameter dropdown list field appears as shown in
the following screenshot.

Assign Parameters

AP Parameters Legacy Application Parameter Information Delete Option
actionFrom NULL null
langCode P_LANGU null

Select v Additionalinput (-]

Figure 9.10: Assign Parameters

12. Select appropriate parameter in the Legacy Application Parameter
dropdown list. This dropdown list is populated with the parameter values
defined in the Adapter.xml file.

13. Corresponding to the Legacy Application Parameter dropdown list, enter
appropriate name in the API Parameters text box.

14. Click Save.

The Assign Parameters screen displays the value as shown in the following

screenshot.

Assign Parameters
API| Parameters Legacy Application Parameter Information Delete Option
Appset P_AFPSET_ID Additionallnput @
actionFrom MULL null
langCode P_LANGU null

Figure 9.11: Assign Parameters
15. Click @ image to delete newly added parameter.

16. Under Assign Fields, click & image to add additional fields to API's.

The Legacy Application Field dropdown list field appears as shown in the
following screenshot.

Assign Fields
Delete

API Field Legacy Application Field Field Alias/Constant Information Option

action Action null

actionText Action_Text null

Language AdditionalOutput @

Figure 9.12: Assign Fields
17. Select appropriate field in the Legacy Application Field dropdown list. This
dropdown list is populated with the fields defined in the Adapter.xml file.
18. Corresponding to the Legacy Application Field dropdown list, enter
appropriate name in the API Field text box.
19. Click Save.

20. The value is added under Assign Fields as shown in the following
screenshot.
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Assign Fields

API Field Legacy Application Field Field Alias/Constant Information g;tt:

En Language ‘ AdditionalOutput O

action Action null

actionText Action_Text null

Figure 9.13: Assign Fields
21. Click @ image to delete newly added field.

Note: you can add additional fields/parameters to API’s only if L image
appears on the screen. @ image appears on the screen only when,
there is no input parameter mapping or output field mapping for any

program parameter or program field. Using & image you should add
at least one parameter or field to the API.

9.31 REMOVE SYSTEM ASSOCIATED WITH API'S

The steps to remove the system associated with API's are as follows:
1. Go to Standard Adapters>Open screen.

2. Select appropriate API and click Add /Remove Systems.
The following screen appears.

Informer — apter Manager Configuration

X I Standard Adapters > Add/Remove System
» Program Workbench

Standard Adapters. Back Save Cancel

= Search

» Custom Adapters | Application Hame SAP_QA
» Auto Batch Extraction | Adapter Hame JDBC_RTA1D

|Frngram Name GET_ROLERANGES_JIDBC10
| API Name: GETROLERAMGES_R10FORSCD

Add System Remove System

Select System Connector
O RTA2 RTAZ
O NEWSYS RTA2

O | PARAMETER_TEST SAPJCO

Figure 9.14: Standard Adapters>Add/Remove System

3. Select the system, which you want to remove and click Remove System.
The associated system is removed.

9.3.2 ADDING MULTIPLE SYSTEMS TO MULTIPLE APT'S

RTA DS facilitates to add multiple systems to multiple API’s in one go.
The steps to add multiple systems to multiple API’s are as follows.
1. Go to Adapter Manager>Standard Adapters>Search.

2. On the Standard Adapters>Search page, select appropriate adapter and
click Open.

The Standard Adapters>Open page opens as shown in the following
screenshot.
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» Program Workbench

b Auto Batch Extraction

Informer Adaptev Manager

x I Standard Adapters > Open

Configuration

| Adapter Description:

| Application Name:

| GRC Application

Oracle R12 Application

APP_PEARSON

RAR

v Standard Adapters Back Add/Remove System APIMapping | Save
Search
b Custom Adapters | Adapter Name: ORAGLE_R12

APIs Mapped Add System Remove System
[ select Al AP APl Name Program Name Program Type ‘System Count
O 2000 GETUSERSYNCFORSOD ORA_R12_GET_USERS STOREDPROCEDURE 4
O 2002 GETUSERACTIONFORSOD ORA_R12_GET_USER_ACTIONS STOREDPROCEDURE 4
[m] 2004 GETUSERPERMISSIONFORSOD ORA_R12_GET_USER_PERMISSION STOREDPROCEDURE 4
O 2006 GETROLESYNCFORSOD ORA_R12_GET_RESPONSIBILITIES STOREDPROCEDURE 4
O 2008 GETROLEACTIONFORSOD ORA_R12_GET_RESP_ACTIONS STOREDPROCEDURE 4
O 2010 GETROLEPERMISSIONFORSOD ORA_R12_GET_RESP_PERMISSION STOREDPROCEDURE 4
O 2012 GETTEXTFILEFORSOD ORA_R12_GET_TXT_QBJ STOREDPROCEDURE 4
O 2014 GETAUTHORIZEFILEFORSOD ORA_R12_GET_AUTH_OBJ STOREDPROCEDURE 4
O 2016 GETUSERORGFORSOD ORA_R12_GET_USER_ORG STOREDPROCEDURE 4
Figure 9.15: Standard Adapters>Open for GRC Application RAR
. . s
3. To map multiple systems to multiple API’s, click Select All.
4. Click Add System.
The System-Connector screen opens as shown in the following
screenshot.
System-Connector [
Select Cancel

Changes will be reflected only after clicking Save button on the Main Page

[] selectan System Connector

O TEST_SYS ORA_CONM -

il GLT_ORATST 5_CONN_22 A

O RAR_CRACLE ORA_CONM A

Figure 9.16: System-Connector
5. Click Select All checkbox to select all the systems.
6. Click Select.

The system gets mapped to the API's and the count is updated on the
Standard Adapters>Open page, under the Systems Count column.

7. Click System Count Link to view mapped System-Connector.

Note: when the mapped system count is greater than zero, then you
cannot edit the System/Connector on the System -Connector

page.

9.3.3 REMOVING MULTIPLE SYSTEMS FROM MULTIPLE API'S

RTA DS facilitates to remove multiple systems to multiple API’s in one go,
thus saves time.

The steps to remove multiple systems to multiple API's are as follows.
1. Go to Adapter Manager>Standard Adapters>Search.

2. On the Standard Adapters>Search page, select appropriate adapter.
3. Click on Open.
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The following screen opens.

I Standard Adapters > Open

Add/Remaove System

» Custom Adapters | Adapter Name:

¥ Auto Batch Extraction | Adapter Description

ORACLE_R12

Oracle R12 Application

v

Figure 9.17: Standard Adapters>Open
4. To remove multiple systems from multiple API’s, click Select All.

5. Click on the Remove System button.

The following screen opens.

| Application Name: APP_PEARSON

| GRC Application: RAR

APIs Mapped Add System Remove System
O 2000 GETUSERSYNCFORSOD ORA_R12_GET_USERS STOREDPROCEDURE 4
O 2002 GETUSERACTIONFORSOD ORA_R12_GET_USER_ACTIONS STOREDPROCEDURE 4
O 2004 GETUSERPERMISSIONFORSOD ORA_R12_GET_USER_PERMISSION STOREDPROCEDURE 4
O 2008 GETROLESYNCFORSOD ORA_R12_GET_RESFONSIBILITIES ‘STOREDPROCEDURE 4
O 2008 GETROLEACTIONFORSOD ORA_R12_GET_RESP_ACTIONS STOREDPROCEDURE 4
O 2010 GETROLEPERMISSIONFORSOD ORA_R12_GET_RESP_PERMISSION STOREDPROCEDURE 4
O 2012 GETTEXTFILEFORSOD ORA_R12_GET_TXT_0BJ STOREDPROCEDURE 4
O 2014 GETAUTHORIZEFILEFORSOD ORA_R12_GET_AUTH_OBJ ‘STOREDPROCEDURE 4
O 2016 GETUSERORGFORSOD ORA_R12_GET_USER_ORG STOREDPROCEDURE 4

System

Changes will be reflected only after clicking Save button on the Main Page

TEST_SYS
O GLT_ORATST
O RAR_ORACLE

6. Click on the Select button.

7. Click on Save.

Figure 9.18: System

The screen displays following message as, <Adapter Name>: Details

saved successfully.

I Standard Adapters > Open

‘ORACLE_R12: Details saved successfully.

| AddRemove System

| Adapter Name:
| Adapter Description:
| Application Name:

| GRC Application

ORACLE_R12
Oracle R12 Application
APP_PEARSON

RAR

e

APIs Mapped Add System Remove System
lsseas A9 Pteme  ewmtem PewenTee  Seencant |
[m] 2000 GETUSERSYNCFORSOD ORA_R12_GET_USERS STOREDPROCEDURE 4
(m] 2002 GETUSERACTIONFORSOD ORA_R12_GET_USER_ACTIONS STOREDPROCEDURE 3
[m] 2004 GETUSERPERMISSIONFORSOD ORA_R12_GET_USER_PERMISSION STOREDPROCEDURE 4
O 2006 GETROLESYNCFORSOD ORA_R12_GET_RESPONSIBILITIES STOREDPROCEDURE 4
O 2008 GETROLEACTIONFORSOD ORA_R12_GET_RESP_ACTIONS STOREDPROCEDURE 3
O 2010 GETROLEPERMISSIONFORSOD ORA_R12_GET_RESP_PERMISSION STOREDPROCEDURE 4
O 2012 GETTEXTFILEFORSOD ORA_R12_GET_TXT_0BJ STOREDPROCEDURE 14
O 2014 GETAUTHORIZEFILEFORSOD ORA_R12_GET_AUTH_0BJ STOREDPROCEDURE 4
[m] 2016 GETUSERORGFORSOD ORA_R12_GET_USER_ORG STOREDPROCEDURE 4

Figure 9.19: Standard Adapters> Open
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Note: If the job is in the Scheduled status, then you cannot remove the
API system mapping.
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10 CUSTOM ADAPTERS

You can configure custom adapters through the AVM-RTA DS Application.

It does not require importing the Adapter XML as in the case of the Standard
Adapters.

The steps to configure a custom adapter for a system are as follows.
1. Create an Application: as mentioned in the Chapter 3.
Create Connectors: as mentioned in the Chapter 4.
Create Systems: as mentioned in the Chapter 3.
Register Application and System: as mentioned in the Chapter 5.

SN

Create a program, which is the part of the custom adapter.

10.1 CREATE PROGRAM

The steps to create a program are as follows.
1. Click the Adapter Manager tab.
2. Click Program Workbench>Program Definition.

The Program Definition> Search screen appears as shown in the screenshot
below.

Informer Adapter Manager Configuration
kS I Program Definition > Search
+ Program Workbench
= Program Configuration
+ Standard Adapters | Name
? S | Description
¥ Custom Adapters
¥ Auto Batch Extraction l GRE Application ~Select-- .
| Program Type —Select-- -
&)
Select Name 7 Description GRC Application Program Type
O |A A RAR STOREDPROCEDURE
) | CUP_AUTHENTICATE JDBC10 Procedure to Authenticate RAR STOREDFUMCTION
© | CUP_AUTHENTICATE _JDBC10 Procedure to Authenticate RAR STOREDFUNCTION
O | CUP_GENERATE_PASSWORD_JDBC10 Procedure to Generate Password RAR STOREDPROCEDURE
© | CUP_GENERATE_PASSWORD_JDBC10 Procedure to Generate Password RAR STOREDPROCEDURE
O | GET_ACTIONLOG_JDBC10 Procedure to get Action Log RAR STOREDPROCEDURE
© | GET_ACTIONLOG_JDBC10 Procedure to get Action Log RAR STOREDPROCEDURE
O |GET ACTION INFO JDBC10 Procedure to get Action Information RAR STOREDPROCEDURE

Figure 10.1: Program Definitions>Search
3. Click on Create.

The Program Definition>Create screen appears as shown in the screenshot
below.
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Informer Adapter Manager Configuration

X I Program Definition > Create

= Program Configuration
+ Standard Adapters | Name:*

* Search
| Description:*

¥ Custom Adapters

» Auto Batch Extraction | Cannection Type JDBC 3

| GRC Application CUP -

| Program Type STOREDPROCEDURE v

| Program *

| Status Active >
| Program Status DRAFT e

|Frogram Detail 1

| Program Detail 2

Figure 10.2: Program Definitions>Create
4. In the Name text box, enter appropriate program name.
5. In the Description box, enter appropriate description.

6. In the Connection Type and Program Type dropdown list, select appropriate
values.

7. In the GRC Application dropdown list, select appropriate option from the
values RAR, CUP and REPORT.

Note: If you select GRC Application as report, based on that you can
configure you can create report under Informer tab.

8. In the Program Type field, select appropriate program type.

Note: if you select GRC Application type as Report, then the Program type
should be QUERY only.

9. In the Program text box, provide the program as defined in the underlying
database to which the connection is to be made to fetch the data.

For example the program is: GLT_ORA_CCRTA.Get_User_Sync(?,?,2,2,2,?)
which is the User Sync program for Oracle Stored procedure.

10. In the Status dropdown list, select the status from the option Active/Inactive.

11. In the Program Status dropdown list, select appropriate status from the
dropdown list.

12. Enter appropriate description in the Program Detail 1 and Program Detail 2
fields.

13. Click on Save to save the record.

10.2 CONFIGURE PROGRAM

After defining the program, next step is to configure the program. Configuring
the program refers to the input and output parameters. This is applicable only in
case of Custom Adapters.

The steps to configure the program are as follows.
1. Click on the Adapter Manager tab.
2. Click Program Workbench>Program Configuration.
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The Program Configuration>Search screen appears as shown in the
following screenshot.

Informer Adapter Manager Configuration
X I Program Configuration > Search
~ Program Workbench
* Program Definition Configure Test Program
Program Configuration
 Standard Adapters | tiame | Adapter Name
* Search | Description | Program Categary Selecte 3
P Custom Adapters
» Auto Batch Extraction | Program Type Select- v | GRC Application Select— v
Go

Select Name / Description GRC Application Program Type Adapter Name ~ Program Category
o |a A RAR STOREDPROCEDURE CUSTOM
(o] CUP_AUTHENTICATE _JDBC10 Procedure to Authenticate RAR STOREDFUNCTION ~ JDBC_RTA10 STANDARD
[e] CUP_AUTHENTICATE _JDBC10 Procedure to Authenticate RAR STOREDFUNCTION  JDBC_RTA10_BCK STANDARD
O | CUP_GENERATE_PASSWORD_JDBC10 Procedure to Generate Password RAR STOREDPROCEDURE JDBC_RTA10  STANDARD
O | CUP_GENERATE_PASSWORD_JDBC10 Procedure ta Generate Password RAR STOREDPROCEDURE JDBC_RTA10_BCK STANDARD
(o] GET_ACTIONLOG_JDBC10 Procedure to get Action Log RAR STOREDPROCEDURE JDBC_RTA10 STANDARD
(o] GET_ACTIONLOG_JDBC10 Procedure to get Action Log RAR STOREDPROCEDURE JDBC_RTA10_BCK STANDARD
O | GET_ACTION_INFO_JDBC10 Procedure to get Action Information. RAR STOREDPROCEDURE JDBC_RTA1)  STANDARD
o] GET ACTION INFO JDBC10 Procedure to get Action Infarmation RAR STOREDPROCEDURE JDBC RTA10 BCK STANDARD

Figure 10.3: Program Configuration> Search
3. Click and Select the defined program and click on Configure.

The Program Configuration>Parameter(s) screen opens as shown in the
following screenshot.

Informer Adamer Manager Configuration

x I Program Configuration > Parameter{s)

~ Program Workbench

= Program Definition Next Cancel

v Standard Adapters | Name GLT_ORA_CCRTA
= Search | Description GLT_ORA_CCRTA
¥ Custom Adapters I script Typs STOREDPROCEDURE
¥ Aute Batch Extraction | Program get_user_sync user_sync_cur IN OUT type_user_syn ... @
Add
Select Name Description Data Type Operator Low Value High Value Parameter Type

[1] < [FPage oo oo

Figure 10.4: Program Configuration>Parameters

4. On this screen, define the input parameters should be added to the program.

Note: the sequence in which the input parameters are defined for the program
should be the same.

5. For Example, we have the program as: GLT_ORA_CCRTA.Get_User_Sync
oracle stored procedure, which is installed at the database of the application.
This is to be analyzed for risk analysis.

6. In this program’s definition, the program looks as below.
a. PROCEDURE get_user_sync
b. user_sync_cur INOUT type_user_sync_cur,
c. in_full incIN VARCHAR?2 :='F,
d. in_date_from IN DATE := NULL,
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10.
11.
12.

13.
14.

e. in_date to IN DATE := SYSDATE,
f. in_user from IN VARCHAR?2 :=NULL,
g. in_user_to IN VARCHAR?2 :=NULL

The input parameters are to be defined in exactly the same sequence, starting
with the cursor and ending at in_user_to.

To define the input parameters click on Add button.

The Parameters screen opens as shown in the following screenshot.

Parameter
Save Cancel

| Mame: =

| Description

| Data Type * --Select- v

| Parameter Type: = _Select-- v

| Operator: * _Select— v

| Refby

| value

Figure 10.5: Program Configuration>Parameters

In the Name text box, enter appropriate with which the parameter is to be
identified.

In the Description text box, enter appropriate description
In the Data Type dropdown list, select appropriate value.

In the Parameter type dropdown list, select appropriate value as IN /OUT
(In many cases, the parameter type is IN, for Oracle’s cursor parameter the
parameter type is OUT).

As per the given example, the first parameter is CURSOR.

Define the input parameter with other values as mentioned in the following
screenshot.

Parameter

Save | Cancel |

Name: * IN_FULL_INC

Description: Full or Incremental

Data Type: * ’ String v ‘

Operator: * ’ Equals VJ

|
|
|
| Parameter Type: * ’ N v ‘
|
| Ref by:

|

Value :

Figure 10.6: Parameters
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15. Define the parameters in exactly the same sequence as per the stored
procedure program installed at the application database.

16. After defining all the program parameters, the Parameters screen appears as
shown in the following screenshot.

Informer Adapter Manager Configuration

x I Program Configuration > Parameter(s)

 Program Workbench

= Program Definition Next Cancel

v Standard Adapters | Mame GLT_ORA_CCRTA
* Search | Description GLT_ORA_CCRTA
¥ Custom Adapters | script Type STOREDPROCEDURE
¥ Auto Batch Extraction | Program gst_user_sync user_sync_cur IN OUT type_user_syn ... @
_Add | | Open Remove

Select Name Description Data Type Operator Low Value High Value Parameter Tyne
© |CURSOR CURSOR cursor = out
€ |IN_FULL_ING full or incremental String = N

[«] <]TPsge 10 oo

Figure 10.7: Program Configuration>Parameters

17. Click on Next.

The Program Configuration>Fields screen opens shown in the screenshot
below.

Note: on the Program Fields screen, click on save to insert the values in the

database.
Informer Adapter Manager Configuration
% I Program Configuration > Fields
“w Program Workbench
+ Pragram Defniion | sae ||| Back || cancel
 Standard Adapters | Name GLT_ORA_CCRTA
= Search | Description GLT_ORA_CCRTA.
¥ Custom Adapters I script Tyne STOREDPROCEDURE
¥ Auto Baich Extraction IProgram get_user_sync user_sync_eur IN OUT type_user_syn ... @
| sortby:
Add
Select Name Description Alias Data Type Sequence No.

Figure 10.8: Program Configuration>Fields

The Program Configuration>Fields specify the output fields that the
program will be returning.

18. On the Program Fields screen, click on Add button.

The Program Configuration>Fields screen appears as shown in the
screenshot below.
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Informer Adapter Manager Configuration
X I Program Configuration > Fields

 Program Workbench

 raorasn Dainliy save || Back || Cancel o &

Program Configuration

v Standard Adapters | Name s B G

» Search | Description
» Custom Adapters | seript Type | Name:*
» Auto Batch Extraction | Program | Description:

I sortby: | DataType:* —~Select— v
| Ales:
Add
Select Name: Data Type

Figure 10.9: Fields

19. Enter appropriate information such as Name, Description and Alias in the
respective text boxes.

20. Select the Data Type from the drop down.

Note: the Alias field is the name of the output column, which is returned by
the underlying program installed at the application. The Alias field is
very important field and it needs to be filled with caution.

21. In the above example: the GET_USER_SYNC stored procedure returns the
data, which is identified by the columns are RTRIM(USER_NAME),
NAME_FIRST, RTRIM(T.NAME_LAST),SMTP_ADDR etc. Enter the field
name exactly the same name in the alias field as returned by the program.

22. In continuation with our example following screenshot shows the
information filled in for the first column named as USER_ID:

Fields
Save Cancel ]
| Name:* USER_ID
l Description: User D
| Data Type: * lString v}
| Alias: RTRIM(T.USER_NAME)

Figure 10.10: Fields

23. In the given example the while run from the database (program is run on the
SQL editor pointing to schema where it is installed) returns the output as
shown:
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<Mo name> ‘
1 ) B[EXEC GLT_ORA_CCRTA.get_user_sync(:1, 'F' null,null,'d’,'Z") &l
The output columns as returned by the program
installed at the applications' database.
These column names are to be used while defining
the output fields for custom adapter
¥
Data Grid 2 x|
5 sta Grid | B uto Trace |7 DaS Output (disabed) | B) Query iewer | Codexpert | xlan plan | s(nuy{utput |
Bl 7 > m ok = K S || Concel
[Q|RTRIMTUSER_NAME) [NAME_FIRST [RTRIM(T NAME_LAST) [SMTP_ADDR [TEL_NUMBER [TEL_EXTENS [DEPARTMENT [[CLASS [EXPIRED_FLAG g
» |AALLEN Atlene Allen kulnupur@gmail.com Pl
AALVI Arianna Alvi nupur kulkami@greenlightcorp.net
AAMBROS Anthony Ambrose
AAPEX AAPEX AAPEX nupurkulkami@greenlightcorp.net
AAUTHORIA Anna Authoria
AAWANG AAWANG AAWANG aawang@yahoo.com =

Figure 10.11: Program Configuration>Fields

24. The output column displays the values such as: RTRIM(T.USER_NAME),
NAME_FIRST, RTRIM (T.NAME_LAST),SMTP_ADDR etc.

25. Click Save to save the created parameters/fields.

It navigates to the Program Configuration> Search screen.

Informer Adap(ev Manager Configuration

% I Program Configuration > Search

 Program Workhench
GLT_ORA_CCRTA : Program configuration saved successfully
= Program Definition

Program Configuration Canfigure Test Program

w Standard Adapters

* Search | Hame: | Adapter Name ©
: ::;‘”E’a"‘::::;mn | Deseription I Program Categary [Fsetect =
| Program Type Selad— =] | GRC Application [~Select- =l
o]

Select Name ¢ Description GRC Application Program Type Adapter Name  Program Category|
€| CUP_AUTHENTICATE_JDBC10 Procedure to Authenticate. RAR STOREDFUNCTION  JDBC_RTA10 | STANDARD
€ | CUP_GENERATE_PASSWORD_JDBC10 Pracedure to Generate Password RAR STOREDPROGEDURE JDBC_RTA10 | STANDARD
€ | GET_ACTIONLOG_JDBC10 Procedure to get Action Log RAR STOREDPROCEDURE JDBC_RTA10 | STANDARD
€ | GET_ACTION_INFO_JDBC10 Procedure to get Action Information. RAR STOREDPROCEDURE JDBC_RTA10 | STANDARD
© | GET_ACTION_PERMISSIONS_IDBC10 | Pracedure to get Action Permission apping RAR STOREDPROCEDURE JDBC_RTA10 | STANDARD
€ | GET_ORGVALUE_JDBC10 Procedure to get Org Value RAR STOREDPROCEDURE JDBC_RTA10 | STANDARD
€ | GET_PERMISSIONACTIITY_IDBC10 | Pracedure to Permission Activty RAR STOREDPROGEDURE JDBC_RTAT0 | STANDARD
€ | GET_PERMISSIONFIELDTEXT_JDBC10 | Procedure to get Permission Field Text RAR STOREDPROCEDURE JDBC_RTA10 | STANDARD
€ | GET_PERMISSIONGROUF_JDBC10 | Pracedure to get Permission Group RAR STOREDPROCEDURE JDBC_RTAT0 | STANDARD
€ | GET_PERMISSIONINFO_IDBC10 Pracedure to Permission Info RAR STOREDPROCEDURE JDBC_RTA10 | STANDARD

L« «J Page e D

Figure 10.12: Program Configuration> Search

26. To test the program go to Program Configuration>Search screen, select the
program name which you want to test and click on the Test Program.

The following screen appears.

Informer Adapt&r Manager Configuration

x I Program Configuration > Test Program
~ Program Workbench

o e T TestProgram || Save || Cancal
| Program Gonnguration |
- — | Program Name GLT_ORA_CCRTA | Description GLT_ORA_CCRTA
< CHIEER AT | Connection Typs JpBC | Program Typs STOREDPROCEDURE
- Search
| Connectar: | Program Details : get_user_sync user_syne_cur N OUT ype_use . @

» Custom Adapters

¥ Aut Batch Extraction Select Connector | Limitto 100 I

| CURSCR (Cursor) | IN_FULLING  (Sting)

Figure 10.13: Program Configuration>Test Program
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27. Enter the parameters. Click on the Select Connector button.

28.

29.

30.

31.

32.

The Connector screen opens.

Connector
Select Cancel -
Select Connector Description
| FRI_CONMN FRI_COMMN
" GRC_10_COMNMECTOR_Z_20_MACHINE GRC_10_Connector_2_20_Maching

Figure 10.14: Connector

Select appropriate connector and click on the Select button. The selected
connector is displayed on the Program Configuration>Test Program screen.

Click on Test Program.

The Program Configuration>Test Program screen appears as shown in the
screenshot below.

| cursor (Cursor) A | NFULLLINC  (String) F

| DATE_FROM  (Date) ] | DATE_TO (Date) o

| USER_FROM  (String) A | user_To ( String ) z

§: 13
[RTRUAT.USER_NAMNE) NANE_FRST RTRIN(T.NAME_LAST) SWTP_ADDR TEL_NUMBER TEL_EXTENS DEPAR]|
AALLEN Arlene Allen kulnupur@gmail.com

AALVI Arianna Alvi nupur.kulkarni@greenlightcorp.net

Figure 10.15: Columns
In the above screenshot, the columns highlighted in red, are the actual
column names returned by the installed program. Enter them into Alias field
while defining the program fields.

Click on Save and the rest of the columns are to be configure on the similar
lines.

Click on Save to save record.

Following the above given steps define the programs and configure the
programs that are to be associated to the custom adapter.

All the other programs: User Action, User Permission, User Org, Role Action,
Role permission, Role Sync, Auth and Text Object, whichever are applicable
are to be defined and configured as per the above steps.

10.3 CREATE CUSTOM ADAPTER

The steps to create customer adapter are as follows.

1.

Go to the Adapter Manager>Custom Adapters>Search.

The Custom Adapters>Search screen appears as shown in the screenshot
below.

Greenlight Technologies, Inc. Page 95 of 123




Geentiont

AVM- RTA Design Studio User Guide v2.0SP07

Informer Configuration

X I Custom Adapters > Search

¥ Program

~ Standard Adapters Create

= Search

~ Custom Adapters | Adapter Name

| Adapter Deseription”

= API Mapping
¥ Auto Batch Extraction | GRC Application : ~Select- v

| Application Name - Seleci A
Go
Select Adapter Name / Adapter Description GRC Application Application

Figure 10.16: Customer Adapters>Search
2. Click on Create.

The Adapter>Create screen appears as shown in the screenshot below.

Informer Configuration

X I Adapter > Create

» Program

~ Standard Adapters Save Cancel

= Search

~ Custom Adapters | Adapter Name:*

| Adapter Description ™

+ API Mapping
» Auto Batch Extraction |1 Shared = o -

| Application Name: * _Select— ~
| GRC Application - —Select— 4
Add Program
Select Program Name Program Description

Figure 10.17: Customer Adapters>Create
3. In the Adapter Name text field enter appropriate name.
4. In the Adapter Description, enter appropriate description.

5. In the Is Shared dropdown list, select appropriate value. Is Shared Flag tells
whether this adapter needs to be shared for different applications. If the same
programs exist for other applications, then the same adapter can be used for
the other applications. Many times the adapter is specific for a particular
application.

6. Inthe Application Name dropdown list, select appropriate application name
for which you want to create the adapter.

7. Inthe GRC Application dropdown list, select appropriate value.

8. Click on Add Program and attach the programs, which you want to associate
to adapter.

9. C(lick on Save to save the newly created adapter.
10. Go to the Custom Adapters>API Mapping.

The API Mapping>Search screen appears as shown in the screenshot below.
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V [ —— r
X I API Mapping > Search
+ Progiam Workbench
* Program Definition | Assign API
= Program Gonfiguration
v Standard Adapters | Program Name: | Program Description:
© Ezel | Application Name: | Assigned API:
+ Custom Adapters | |
o Ceste/semch | |Adspterhiame GRC Application - [~select- <
API Mapping Go
~w Auto Batch Extraction
= Job-AP| Search
= Job Scheduler ©  REPORT1 Custom API ORACLE ORACLE REPORT

Figure 10.18: API Mapping>Search

11. Enter the search criteria as the custom Adapter Name, to segregate the
programs for which you want to perform API mapping.

12. Select the program and click on Assign API button.
Adapter Manage: r

% [ A»1Mapping > Assign APt

~ | Appicaton Name: ORACLE APPLICATION
| Adagter Hame: ORACLE_CUSTOM_ADAPTOR
| | Program tame: USER_ACTION_DELAY
| AP Name: [GETuserACTONFORSOD =
TS — o Add System | Remove System |
€ ORACLE SYSTEM ORACLE 5.3

OO mE OO
Figure 10.19: API Mapping>Assign API

13. Select the API Name from the dropdown list.

14. Click on Add System, to associate the System and connector to this API as in
the following screenshot.

Adapter Manages

x l AP Mapping > Assign API

. e
| | Appicaton Name: ORACLE APPLICATION
| Asapter Name: ORACLE_CUSTOM_ADAPTOR
| Program Name: USER_ACTION_DELAY
| 4P Name:

System-Connector
C—

19 ORACLE SYSTEN [oraciesa =
L REPORT SYSTEM [oracLE connecTor =l
L. |

Figure 10.20: API Mapping>Assign API
15. Click and Select appropriate system and connector.
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16. Click on Continue. The following screen appears. Map the parameters and
fields to the SAP GRC input parameters and output fields.

r Adapter Manager r

X I API Mapping > Assign APl > Assign Fields

¥ Program
oo
+ Search
 Custom Adapers | API Name: GETUSERACTIONFORSOD | Program Name: USER_ACTION_DELAY
* Create / Search | Application Name: ORACLE APPLICATION | Program Type: STOREDPROCEDURE
| Adapter Name: ORACLE_CUSTOM_ADAPTOR | Program GLT_ORA_CCRTA Get_User_Action_time(?.7) @

» Auto Batch Extraction

Assign Parameters

Assign Fields

User_Name
userld | USER_NAVE v

Resp_Id
role |RESP_D v

Function_Name
fromAction | FuncTon_name | -

Aol Name

Figure 10.21: API Mapping>Assign API>Assign Fields

17. Under Assign Parameters, select appropriate parameter of the program from
each of the dropdown list. It tells the RTA DS, which parameters of the SAP
GRC request, needs to be mapped to which parameters of the program
installed at the applications” database.

Assign Parameters
fetchType IN_FULL_INC v
fromUserld USER_FROM v
toUserld USER_TO v
fromDate DATE_FROM v
toDate DATE_TO v

=
Figure 10.22: API Mapping>Assign API>Assign Fields
18. As per our example, the mapping is done as shown in the screenshot below.
Assign Field mapping as in the screenshot below.

Assign Fields
userld USER_D v RTRIM(T.USER_NAME)
firstName NAME_FIRST N NAME_FIRST
lastName NAME_LAST v RTRIM(T.NAME_LAST)
emailAddr EMAIL_ID e SMTP_ADDR
telNumber NULL v
department DEPARTMENT ¥ DEPARTMENT
userGroup NULL v
deletionFlag NULL v
telExtens NULL v

Figure 10.23: Assign Fields

19. Map only those fields, which are returned by the program and leave the rest
as null, except for the mandatory fields like User Id, Last name for User
Sync.

20. Click on Save.

21. Similarly do the API field mapping for all the programs in the adapter and
do the risk analysis for the System associated with this custom adapter.
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11 AUTO BATCH EXTRACTION

Auto Batch Extract delivers the data required by SAP RAR in the Flat File Format.

You can generate the Flat Files as per the selected APIs in the Auto Batch Extract at
a predefined location, specified internally in the RTA DS. Then the flat files are
imported into the SAP RAR manually for risk analysis.

Once the Application and the System is selected, the APIs available for that
connector or the system is enabled for the user to choose the files to be generated.

Apart from this, enter the range of users and the roles for which the risk analysis
data is to be generated.

A history is maintained for all the jobs created through Auto Batch execution. It
stores the input parameter values for different APIs selected in that job.

11.1 SCHEDULED JOBS

The Scheduled Jobs menu enables the user to create/copy and edit the existing
jobs/cancel the scheduled jobs and View the existing jobs.

1. The jobs are scheduled for the frequencies: Immediately, Once, Daily,
Weekly and Monthly.
2. The scheduled Job can be cancelled/copied/edited.

3. The Copy and edit always have the same job name but the user can go and
change the description for the Job name. A new Job instance is created having
the same name but with a new sequence number and can be scheduled at any
of the existing frequencies.

11.1.1 JOB SCHEDULER SEARCH

The steps to search scheduler are as follows.

1. Click Adapter Manager Tab.
2. Click on Auto Batch Extraction in the left menu bar.
3. Click on Job Scheduler.

The Auto Batch Extraction>Job Scheduler screen opens as shown in the
screenshot below.
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Informer ndamer Manager Configuration
* I Auto Batch Extraction > Job Scheduler
} Program Workbench
v Standard Adapters Create Copy & Edit Cancel Job M Date Format : {mm-dd-yyyy)
« Search
+ Auto Batch Extracton | Name: | Descrition
* J0b-API Search | Application | system
| Frequency: | Next Run Date: ]
| Start Date: ] | End Date: 5]
| status: | Created By
&
Select Name Deserigion :‘:"e‘“mm System Frequency  StartDate EndDate + NedRunDsle  Stahus Created By
O ORACLER12 ORACLER12 1 ORACLE ORACLE R12 IMMEDIATELY COMPLETED SAPUSER
O ORACLE ORACLE 6 ORACLE ORACLE IMMEDIATELY COMPLETED sapuser
O ORACLE_22 ORACLE 22 1 ORACLE ORACLE IMMEDIATELY FALED SAPUSER
Figure 11.1: Auto batch Extraction>Job Scheduler
4. Enter any one of the fields as search parameter and click Go. To view all,
simply click Go
The “Auto Batch Extraction>Scheduled Jobs >Search’ screen displays the
Searched Auto Batch Extraction Information.
5. The details are displayed under the column headings Select, Name,
Description, Sequence No., Application , System , Frequency , Start
Date, End Date , Next, Run Date, Status, and Created By .
6. To View the Job details, select the job which you want to view and click
on View.
11.1.2 JOB SCHEDULER CREATE
The steps to create, copy or edit job scheduler are as follows.
1. Click Adapter Manager Tab.
2. Click on Auto Batch Extraction in the left menu bar.
3. C(lick Job Scheduler.
The Auto Batch Extraction > Job Scheduler screen opens as shown in the
following screenshot.
Informer Adapter Manager Configuration:
X I Auto Batch Extraction > Job Scheduler
¥ Program Workbench
o ST AT Create || Copy & Eat Canceldob || View | Date Format : (mm-dc-yyyy)
= Search
 Auto Baich Extraction | Hame: | Description
= Job-API Search | Appiication | eystem:
| Frequency: | Next Run Date: i
| start Date: o | £nd Date: ]
| status: | Created By:
=)
Select Name Description r‘mm ‘System Frequency Start Date End Date © ‘Next Run Date Status Created By
O ORACLER12 ORACLE R12 1 ORACLE ORACLE_R12 IMMEDIATELY COMPLETED SAPUSER
O ORACLE ORACLE ] ORACLE ORACLE IMMEDIATELY COMPLETED sapuser
O ORACLE_22 ORACLE 22 1 ORACLE ORACLE IMMEDIATELY FAILED SAPUSER
O INFOLEASE INFOLEASE 1 INFOLEASE INFOLEASE IMMEDIATELY COMPLETED SAPUSER

Figure 11.2: Auto Batch Extraction>Job Scheduler
4. To create the new job scheduler, click on Create.
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The Auto Batch Extraction>Create screen appears as shown in the

screenshot below.

¥ Custom Adapters

w Auto Batch Extraction
| Name:
= Jop-4PI Search

Job Scheduler

| Description

Informer Adamer Manager Configuration
% ] Auto Batch Extraction > Create
» Program Workbench
¥ Standard Adapters Next Cancel

| Application: I—SElEE‘*

L

I'system  [selea

| Max.Lines: 10000

| createFile:

P NG

10.

Figure 11.3: Auto Batch Extraction>Create
In the Name field, enter appropriate name.
In the Description, field, enter appropriate description
In the Application dropdown list, select appropriate application.
In the System drop down list, select appropriate system.

Note: the Application/System dropdown list displays the registered
applications/systems. The Application/System is registered under
the Configuration>Registration.

The Max Lines text box, displays value as 10000.

The Create File checkbox is marked/unmarked, based on the selection of
the Application and System. There are two cases.

a. Case 1: the Create File checkbox is checked. In this case, when you
select appropriate Application and System the create file
checkbox is checked. This happens in case of online (real time)
analysis mode. During the online (real time) analysis, it creates zip
file for data from ERP. The setting for the online (real time)
analysis is configured while creating a system, under the
Configuration>Application Center>System-Create, uncheck the
RTADS Repository checkbox. The following screenshot
demonstrates the Create File checkbox is checked.

Informer Adap\ev Manager

Configuration

% ] Auto Batch Extraction > Create
» Program Workbench

 Standard Adapters M Gancel
« Search
¥ Custom Adapters
 Auto Batch Extraction
= Job-4FI Search

Job Scheduler

| Name:* FRI1

| Description:  [FRi7|

| Application* [ _spp

L] 1]

| system: [FRisvs

| max Lines 10000

| Create File o4
APIs*

l [ GETUSERSYNG l [T GETUSERACTION | [ GETUSERPERMISSION

I [ GETROLESYNC I ™ GETROLEACTION

I ™ GETROLEPERMISSION

I [ GETTEXTFILE I I GETAUTHORIZEFILE I ™ GETUSERORG

Figure 11.4: Auto Batch Extraction> Create

b. Case 2: the Create File checkbox is unchecked. In this case, when
you select appropriate Application and System the create file
checkbox is unchecked. This happens in case of offline analysis
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mode. During the offline analysis, you can create .zip files as
required. The setting for the offline analysis is configured while
creating a system, under the Configuration>Application
Center>System-Create, check the RTADS Repository checkbox.
The following screenshot demonstrates the Create File checkbox
is checked.

4

Adapter Manager r

% ]| Auto Batch Extraction > Create

» Program
w Standard Adapters

= Search
} Custom Adapters

= Job-API Search

Job Scheduler

w Auto Batch Extraction

| Name= Sys1

| Description:  [gyz1

| Application= | FRI_APP ;I
Isysem=  [FRSvS =
| Max Lines 10000
I CreateFile: [
APIs*
| I cerusersvie | seruseracmion | ™ cemuserreRmIssION
I cerroLesmc I ™ Gerrotescrion I ™ cetroLerermssion

I cerrexrLe | cerautrorizeriLe I ceruserore

11. Check

Figure 11.5: Auto Batch Extraction> Create
the checkbox, corresponding to the required API.

12. To schedule a Job, click on Next.
The Auto Batch Extraction> Create> Configure Input screen opens as

shown

in the screenshot below:

Note: based on the selected API’s the Auto batch Extraction>Create>
Configure Input screen displays the number of API’s on the screen.

x I Auto Batch Extraction > Create > Configure Input

Figure 11.6: Auto batch Extraction>Create>Configure Input
13. Click ¥ image/Expand All corresponding to APL
The Parameter Name and Parameter Value field appears on the screen.

I Auto Batch Extraction > Create > Configure Input

Feich Type

-

From Date

From Userid

To Date

To Userid

Figure 11.7: Auto batch Extraction>Create> Configure Input

14. Enter appropriate parameter value corresponding to each parameter.
15. Click Next.
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The following screen appears.

Informer Adapter Manager Configuration
] Auto Batch Extraction > Schedule
¥ Program Workbench
+ Standard Adapters Back Schedule Cancel
= Search
+ Auto Batch Extraction IFrequency: 3 yyyepiarery
= Job-API| Search
-
O once s
) DAILY AtEvery hr min
) WEEKLY On Every Sun Mon Tue Wed Thu Fri Sat
hr min
O MONTHLY On Every Day hr min
| Start Date - ]
| End Date : o

Figure 11.8: Auto batch Extraction>Schedule

16. Select the frequency from the options: Immediately, Once, Daily,
Weekly or Monthly.

17. For the frequency daily, weekly or monthly, enter the Start Date and the
End Date.

18. To save the record and schedule the Job, Click on Schedule.

19. The application displays message, “<Job Name>: Details saved and job
scheduled successfully.

Note: if the OFFLINE flag is selected for the SYSTEM, the data generated for the
APIS such as GETUSERSYNC, GETUSERACTION,
GETUSERPERMISSION, GETROLESYNC, GETROLEACTION,
GETROLEPERMISSION scheduled in the JOB will be stored in the RTA
DS tables for the respective API. File will be created for AUTH and
TEXT APIs.

11.1.3 JOB SCHEDULER COPY AND EDIT

The steps to copy or edit job scheduler are as follows.

1. Click on Adapter Manager tab.
2. Click on Auto Batch Extraction in the left menu bar.
3. C(lick Job Scheduler.
The Auto Batch Extraction>Job Scheduler opens.
4. Click and Select the job name, which you want to copy/edit.
5. Click on Copy & Edit.

The Auto Batch Extraction> Open screen opens as shown in the
screenshot below.
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Informer

Adapter Manager

Configuration

X I Auto Batch Extraction > Open

» Program Workbench
 Standard Adagters
« Search
¥ Custom Adapters
~ Auto Batch Extraction
+ Job-AP| Search

Job Scheduler

Next | Cancel

I name:* CHECK
| escription

| Appication*

| System

I Max Liness 10000

APIs’

| & cerermssionactvt_rio

| O cerrermssionrLon_rio
| [ cerprorLEPERMSSION_R10
| @ cemuseracrion rio

| @ cerroLeaction R0

1 O ceraumomzerLe_R10

| @ ceracrionro_r1o

| & cerusesrotes w10

| & ceruserrances k1o

| [ cenereaTerassworo_R10

| ] GETPERMISSIONINFO_R10

| ’:! GETPERMISSIONGROUP_R10
| D GETHREMPLOYEEDTLS _R10
| & ceruserrermssion_r10
g GETROLEPERMISSION_R10

| O eemuserore k1o

| g ‘GETPERMISSIONTEXT_R10

| 2] GETROLESFORUSER_R10

I E GETROLERANGES_R10

| & oerorovaLe_rio

| D GETACTIONLOG_R10

| D GETPROFILEACTION_R10

| & cerusersyie_Rio

| @ cemmoteswic_rio

| (1 cermextrLe_rio

| 01 cemroLeors_Rio

| GETACTIONPERMISSIONS _R10
| GETROLESFORACTION_R10

| O autHenmicate_rio

Figure 11.9: Auto batch Extraction>Open

Y NS

The Name field is not editable.
Edit the other fields as required.
To schedule Job, click on Next.

Refer and follow the similar steps as mentioned under 11.1.2 JOB

SCHEDULER CREATE- steps 11 to 18.

11.1.4 CANCELLING JOB

You can cancel the job whose status is IN-PROCESS or SCHEDULED. When
you cancel the job, its status will change from IN-PROCES/SCHEDULED to
MARKFORCANCEL. The Job canceller thread runs every 5 second and
cancels the IN-PROCESS jobs, which is MARKFORCANCEL. Then the job
status is changed from MARKFORCANCEL to CANCELLED.

The steps to cancel the job are as follows.
1. Click on the Adapter Manager tab.
2. Click on the Auto Batch Extraction in the left menu bar.
3. Click Job Scheduler.

The Auto Batch Extraction>Job Scheduler opens as shown in

following screenshot.

» Program Workbench
v Standard Adapters
= Search
¥ Custom Adapters
 Auto Batch Extraction
- Job-API Search

Job Scheduler

Informer Adanlel Manager

x I Auto Batch Extraction > Job Scheduler

the

Configuration

Create | Copy&Edit | Cancellob | View |

| Name: |

| Application:

| Frequency [setect- =l

| start Date [

| status: [~serea- =l
|Go]
Select Name Description S:q"e""e Application System
© JDAALL_APIS JDA_APPL JDA_SYS
©  JDAALLAPIS JDA_APPL JDA_SYS
€ IDA_ALL_APIS JDA_APPL IDA_SYS

Date Format : (mm-dd-yyyy)

| Description

| system:

| Next Run Date
| End Date:

| created By:

Frequency Start Date EndDate ¥ Next Run Date.
IMMEDIATELY
IMMEDIATELY

IMMEDIATELY

Status

FAILED

COMPLETED

FAILED

Created By
Test_0A
Test_0A

Test_0A

Figure 11.10: Auto batch Extraction>Job Scheduler

Greenlight Technologies, Inc.

Page 104 of 123




AVM- RTA Design Studio User Guide v2.0SP07

Geentiont

4. Select the job whose status is IN-PROCESS or SCHEDULED.
5. Click on the Cancel Job.

The following message appears on the screen.

f

b3

2

Are you sure Do wou wank ko cancel the job?

l Ok ] [ Cancel

]

x|

Figure 11.11: Message

6. Click on the OK button.
The screen displays message as shown in the following screenshot.

Informer Adanlar Manager Configuration
% I Auto Batch Extraction > Job Scheduler
» Program Workbench -
s— JDA: Jobis marked for cancellafion.
o @ Create |  Copy&Edit Cancel Job | View
» Custom Adapters
 Auto Batch Extraction I Name: JDA
= Job-APl Search I Application
Job Scheduler
| Frequency. [“setect- =l
| Start Date: ]
| Status: [~Selea- =
Go
Jr— » Sequence , .
ame Description 5 Application System
oA DA 1 JDA_APPL JDA_SvS

Frequency

IMMEDIATELY

Date Format : (mm-dd-yyyy)

| Description

| system:

| NextRun Date: o
| End Date: o

| Created By

Start Date EndDate T NextRunDate  Status Created By

MARKFORCANCEL Test QA

Figure 11.12: Auto batch Extraction>Job Scheduler

Note: you cannot cancel the job whose status is Completed/Failed/Cancelled.

11.2 JOB API SEARCH

This JOB-API menu stores the information for the various API runs included in a

particular Job.

It briefs the Job Name, Sequence Number, Application and System Name for
which it was scheduled and the associated APIs.

It briefs the status of the various APlIs, the time at which they run and whether
they are completed. It specifies the path where the data is generated after the API

run.

1. Click on Adapter Manager Tab

2. Click on Auto Batch Extraction in the left menu bar.
3. C(lick Job-API Search.

4,

screenshot below.

The Auto Batch Extraction> Job-API Search screen opens as shown in the
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Infarmer Adapter Manager Configuration

NI Auto Batch Extraction > Job-API Search

Date Format : (m

| Mame: | Deseription
| 2pplication | system:

| 471 Mame: Select- [ | Filz Mame

~
GETUSERSYNC_R10
GETUSERSYNC b
| Frequency: —Salect- ~] | status: [Seka- ~]
| Start Date: ] | End Dte: o
Go
Run s
Id  Mame Deseription N:““E""E Application  System API Name File Name Frequency Status Start Date End Date Sarver Node
= '
2000 25ER User syne 1 ORACLEAPPS| ORACLESYS GETUSERSYNC R0, __ IMMEDIATELY COMPLETED 08-01-2018 16:03:38 05-01-2018 18:04:00 P12_01_server.

NG

batch 2000.z

Figure 11.13: Auto batch Extraction>]Job-API Search
5. To search a particular record, enter any one of the fields as search parameter
and click Go.
-Or-
To view all records, click Go.
6. The Auto Batch Extraction >Job-API Search screen displays the search
results under the column headings Run Id, Name , Description, Sequence

No., Application, System, API Name, File Name, Frequency , Status, Start
Date, End Date and Server Node on which job is being executed.

Note: in Auto Batch Extraction > Job-API Search Screen, each field is a
search criterion. You can enter any field and click Go. Howeuver, if you
want to search for a particular request, enter the unique field and click
Go.

7. To download the generated file, click on the Filename link.

Note: the Auto-Batch Scheduler process creates files in the RTADS_FILES
folder on the NetWeaver Java Stack where the application is deployed.
Monitor the RTADS_FILES folder for the occupied space to ensure
that the space constraints are not violated. If you want to delete a file
created by the Auto-Batch process from this location, it will not be
available from the RTA DS application through the Auto Batch
Extraction > Job API Search- File Name link. So if you do not want to
refer the the auto batch job files in future, they can be deleted from the
RTADS_FILES folder.
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12 CUSTOM REPORTS

Before you create custom report ensure the following things are in place.

1.

12.1

Under the Adapter Manager> Program Workbench> Program Definition,
create Program Definition with GRC Application as REPORT and Program Type
as QUERY.

Under Adapter Manager> Program Workbench>Program Configuration, add
parameters and fields while configuring program configuration.

Under Configuration>Connectors, create connector for reports.

Under Configuration>Application Center>Systems, create a system and add
connectors created for report to it. Select the value in the Connector For
dropdown list as Report.

Proceed to informer tab, to create a report.

CREATING CUSTOM REPORTS

The steps to create custom reports are as follows.

1.
2.

Click on the Informer tab.
Under Reports, click Reports.

The Reports page opens as shown in the following screenshot.

% I Reports
¥ Reports

| Hame:

| Deseription:
Go

Select Name Description Program Connector System

[e[ease] o> [v]

Figure 12.1: Reports
Click Create to create new report.

The Reports>Create screen opens as shown in the following screenshot.
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e T

X I Reports > Create
» Reports

| Name GL_ACCOUNT_POSTINGS

| Description* GL_ACCOUNT_POSTINGS

| Program Type:*

| Program Hame:* GL_ACCOUNT_POSTINGS -

| Program: * SELECT LACCOUNT -
AS "ACCOUNT",L.CURRENCY_CD
AS "CURRENCY_CD",L MONETARY_AMO  ~¥

| system:* PEOPLESOFT S

| connector:* FINGBORA -

Figure 12.2: Reports>Create
4. In the Name text box, enter appropriate name.

5. In the Description, enter appropriate description.

6. By default the Program Type, dropdown list is populated with the value as

QUERY.

7. In the Program Name dropdown list, select the program name created for

reports through Program Workbench.

8. Based on the program configurations done for Program name, the Program

tield is populated.

9. In the System dropdown list, select appropriate system for reports.

10. In the Connector dropdown list, select appropriate connector associated in

that system.
11. Click on Save.

The Reports screen lists reports.

The screen displays message as, “<Report name>: Report(s) saved

successfully.
Informer ‘Adapter Manager Configuration
x I Reports
» Reports
GL_AGGOUNT POSTINGS : Report(s) saved successfully.
Create Open
| Name
I Description
Go
Select Name # Description Program System Run Report Status
© | GL_ACCOUNT_POSTINGS GL_ACCOUNT_POSTINGS GL_ACCOUNT_POSTINGS| FINS8ORA PEOPLESQFT Run Report COMPLETED

Figure 12.3: Reports
12. Click on the Run Report link.

The Reports> Run Report screen opens as shown in the following

screenshot.
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Informer

¥ Repors

r

r

» I Reports > Run Report o

Show Report Layout Save Report

SYSTEM_ID J0_DVa11
MANAGER_ID
Load Report Data__ | Run Report | [ Reaktime Data Fetch |

| | | | \ | \ | | |
Figure 12.4: Reports>Run Report

12.2 CONFIGURING REPORT

1.

The steps to configure reports are as follows.
Go to Informer> Report.

The Report screen opens.

2. Click and Select the report, which you want to configure.
3. Click Open.

The Reports>Opens.
4. Click Configure Report.

The following screen opens.

H

-
b Reports
] Show Report Layout Save Report

SYSTEM_ID

M
SAPUSER

MANAGER_ID

Load Report Data | Run Report | | Realtime Data Fetch

"]

KYEUNG POCACKOO1 ACT T-CODE T-CODE PO411-ALLMOS11A  |ROLE ARD2 JDE_SYSTEM
KYEUNG POO1CKOO1 ACT T-CODE T-CODE POAMMZ-ALLWIA0M2A | ROLE PROM JOE_SY'STEM
KYEUNG POO1CKOO1 PRI PO411-ALLIVO411A | ACTWT o] ROLE ARD2 JDE_SYSTEM
KYEUNG POCACKOO PRI PO&T1-ALLIVOETIA  MCU gMcu ROLE ARD2 JDE_SYSTEM
KYEUNG POO1CKOO1 PRI PO4012-ALLIWO040124  ACTVT o] ROLE PRO JOE_SYSTEM

Figure 12.5: Reports>Run Report
Note: if the report contains input parameters, then the above screen (figure
12.5) opens while configuring report. It is mandatory to add at least
one input parameter. If there are no input parameters, then while
configuring the report, the screen opens as shown in the screen 12.6
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5. Enter appropriate values for the Input parameters. For Example in the
following screenshot enter parameter values for SYSTEM_ID and
MANAGER_ID.

6. Select Real-time Data Fetch in the dropdown list and click Run Report.
The report data gets displayed under the columns.

Note: use Real-time Data Fetch option, when you want to retrieve real time
data.

7. Click Load Report Data to load data into RTA DS table.

Note: the Load Report Data helps to retrieve data faster.
8. Select the Offline Data Fetch in the dropdown list and click Run Report.

The report data is displayed under the columns.

Note: when you want to retrieve data stored in the table, use Offline Data
Fetch option.

9. Click Show Report Layout.

The following screen opens.

X I Reports > Run Report > GL_ACCOUNT_POSTINGS Data loaded successi
» Reports
Show Input Parameters Save Report | el
Column Filters - Column Alias.
Column Criteria Clear All Select All Column Alig
ACCOUNT Clear ACCOUNT
CURRENCY_CD Clear CURRENCY_CD cu
TOTAL_AMOUNT Clear TOTAL_AMOUNT TO
ABSOLUTE_TOTAL_AMOUNT Clear ABSOLUTE TOTAL AMOUNT |as:
FOREIGN_CURRENCY Clear I = FORFIGN CIIRRENCY
Load Report Data Run Report Real-time Data Fetch v

ACCOUNT CURRENCY_CD TOTAL_AMOUNT ABSOLUTE_TOTAL_AMOUNT FOREIGN_CURRENCY

Figure 12.6: Reports>Run Report

10. Column Alias, displays the list of columns under the Column heading
Column, Alias and Seq No. as shown in the following screenshot.

Column Alias

Select All Column Alias Seq. No.
ACCOUNT ACCOUNT 1

CURRENCY_CD CURRENCY_CD 2
TOTAL_AMOUNT TOTAL_AMOUNT

K3

ABSOLUTE_TOTAL_AMOUNT |ABSOLUTE_TOTAL_AN|| 4

g

FORFIGN ClIRRFNCY FORFIGN CIIRRFNCY |5

Figure 12.7: Column Alias
11. To load data for all the columns, click Select All and Run Report.

Data is displayed on the screen under each defined column as shown in the
following screenshot.
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12.

13.

14.

15.

16.
17.

Reports > Run Report > GL_ACCOUNT_POSTINGS

Data loaded successi

Show Input Parameters

l Categorize I Save Report

1

ACCOUNT 1 Clear ACCOUNT ACi

CURRENCY_CD ] Clear CURRENCY_CD @

TOTAL_AMOUNT ] Clear TOTAL_AMOUNT [To]

HESEILLTIE TETAL AT L 1] lizn ABSOLUTE TOTAL AMOUNT |25

FOREIGN_CURRENCY Clear = FORFIGN CHRRENCY [eol
Load Report Data | Run Report | | Real-time Data Fetch hd ‘

206100 uso 610.06 610.06 AUD
206100 uso 40637 40637 AUD
206100 uso 6069 .01 6069 01 AUD

Figure 12.8: Reports Run Report

The Alias column facilitates to rename the existing column. To do this, enter
appropriate name of the corresponding column, in the Alias text box.

Under Seq No, you can edit the current sequence of the columns and set
new sequence. The screen loads data, based on the set sequence. To do this,
enter the sequence in the Seq no. text box, corresponding to each column.

Under the Column Filters, enter the filter criteria in the Criteria text box and

click Run Report.

The screen loads data, based on the defined criteria.

Click on Show Input Parameters, to view and edit input parameters if

required.

Click on Save Report to save the record.

To load data in the excel file, click the icon as shown in the following

screenshot.

r u

Informer

r

x I Reports > Run Report

} Reports

Show Report Layout

Save Report

SYSTEM_ID Hof_SYSTEM
MANAGER_ID Download Print|=rUser
o Excel
Load Report Data | Run Report ‘ | Realtime Data Fetch R4 |

KYEUNG

POO1CKOO1

T-CODE

T-CODE

POAT1-ALLIVDAT1A

ROLE

ARDZ

JDE_SYSTEM

KYEUNG

POO1CKOO1

T-CODE

T-CODE

PO4012-ALLWD40124

ROLE

PRO1

JDE_SYSTEM

KYEUNG

PO01CKOO1

PO&T1-ALLWDA11A

ACTVT

a

ROLE

ARDZ

JDE_SYSTEM

KYEUNG

POO1CKOO1

PRM

PO&T1-ALLWDAT1A

Mcu

SWcu

ROLE

APDZ

JDE_SYSTEM

Figure 12.9: Reports>Run Report

18. The File Download dialog box opens as shown in the following screenshot.
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Do you want to open or zave this file?
@ Mame: GL_ACCOUNT_POSTINGS. xls

1Hl Type: Microsaft Excel 97-2003 Warksheet
From: 192.168.2.58

Save Cancel

J |

Always ask before opening this type of file

J

Open

Wwhile files from the Internet can be uzeful, ome files can patentially

I\al harrn your computer. If you do nat trust the zource, do not open or
= zave thiz file. ‘what's the risk?

Figure 12.10: File Download

19. Click Open. The excel file with data opens as shown in the following

screenshot.
&9~ s Micosoft Exce o B R
Home Insert Page Layout Farmulas Data Review View & @
Arial s - = =g =' General - A S=lnsert~ X - 47~ o j
B 7 U- A & = 8% . & Delete ﬂ' 8-
yles | L, i e W
O A o W V romats | 20 mgre e
Font Mumber Cells Editing WebEx
Al - v
u IZ_I] mportDataToExel.do [Read-Only] [Compatibility Mode]
A B i D E F G H | J M
1
2 RISKRULE PRMTYPE PERMISSI FIELD VALUE_IDROLE_IDY FUNCTIONSYSTEM_ID
3 KYEUNG |PO0MCKOQACT T-CODE |T-CODE |PO411-ALIROLE APO2 JDE_SYSTEM
4 KYEUNG [PO01CKOQACT T-CODE |T-CODE |PO4012-AlRCOLE FRO1 JDE_SYSTEM
5 KYEUNG |PO0TCKOOFRM PO411-ALLACTVT 8] ROLE APDZ2 JDE_SYSTEM
6 KYEUNG |PO0TCKOOFPRM PO411-ALLMCU SMCU ROLE APDZ2 JDE SYSTEM
T KYEUNG |PO0TCKOOFPRM PO4012-AACTVT 8] ROLE PRO1 JDE_SYSTEM
§ KYEUNG |PO0TCKOOFPRM P04012-A0MCU SMCU ROLE PRO1 JDE SYSTEM
9 KYEUNG |PO0MCKI0ACT T-CODE |T-CODE |PM11-ALIROLE APDZ2 JDE_SYSTEM
10 KYEUNG [POMCKAQACT T-CODE |T-CODE |P04012-AIROLE PRO1 JDE SYSTEM
11 11 KYEUNG |PO0MICKAOFRM PO411-ALLACTVT (D ROLE APRO2 JDE_SYSTEM
112 KYEUNG |POCKIQPRM FO411-ALLMEL FMCU ROLE ARO2 JDE_SYSTEM
1] 13 KYEUNG |PO0ICKI0PRM PO4012-ALACTVT [0 ROLE PRO1 JDE_SYSTEM
1 14 KYEUNG |POOTCKIQPRM PO4012-ALMEL sMCU ROLE FRO1 JDE_SYSTEM
1115 KYEUNG |PO0ICK2QACT T-CODE |T-CODE |PO4012-AlROLE PRO1 JDE_SYSTEM
! A6 KYELIMG [PONTCK2IACT T-CONFE _IT-COnE  1Pnd11-al RO E ﬁﬂ? ANE _SYSTEM _
Ready | ||EB|E E 100% (=) [ {(+)

20. On the Reports>Run Report screen, click Print icon to get print out of the

data.

Figure 12.11: Excel file with data
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13 LOGS MONITOR

The Logs are available and can be viewed either through the application or directly
on the server as an operating system file.

The AVM-RTA DS maintains error and debug logs at following server operating
system path: /usr/sap/<SID>/../j2ee/cluster/ RTADS_LOGS

To see the logs from the RTA DS application, please follow this path:

Configuration >Logs Monitor >Application Log >xapp error log and
xapp.debug.log

1. Click Configuration tab.
2. Click Application Logs under Logs Monitor in the left menu bar.
3. The Application Log > screen opens as shown in the screenshot below.

e
® I Application Log >
= Registration
+ Connectors Name Size Last Modified Date Time  #
b ST e P12 01 server! 18386651 07-29-2016 18:06:27
b Utilities
) P12 01 serverd 19386650 07-29-2016 18:06:27

w Logs Monitor

prr———— P12 01 server? 19386652 05-01-2016 16:03:56

[4][4] Page 1 1]

Figure 13.1: Application Log >View Screen
4. The Application Log>View table displays Name column with Node link and
last modified date time.
5. Click on the Node link.

6. The Application Log > <Node link> >View screen opens as shown in the

following screenshot displaying details under columns Name, Size and Last
Modified Date Time.
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I Application Log > P12_01_server1_19386651

Name Size Last Modified Date Time #
Xapp efmor.log 623 KB 03-01-2016 15:10:37
¥app info.log 34 KB 08-01-2016 15:53:44
xapp debunlog 1104 KB 08-01-2016 17:00:56

L]« I Paoe il Ono
Figure 13.2: Application Log > Node

7. Click on the Name link to view and download the log files.

8. Click on the breadcrumb link to visit application log page.

9. The Log files are used by administrators to view the status of the system,
database, and applications. The AVM-RTA DS logging API uses the log4j to
produce logs in a common format and the status of the log files can be displayed
using a browser. The actual log files are invoked using a hyperlink to individual
log file. Log files are automatically written and contain a predefined severity
that cannot be modified in the current release.

For debugging purposes, apart from the logs provided by RTA Design Studio;
the logs available from NW AS Java and the default log and trace file for the J2EE
engine can also be referred.

10. There are primarily three levels of severity it supports:

1. Error
2. Info
3. Debug

11. Each log file records the following events:
1. Source of the record

2. Event timestamp
3. Message
4. Severity Level
The following table shows the list of important log objects.

/usr/sap/<SID>/]JC<instance Default location of AS TAVA loe fil
nor.>/j2ee/ cluster/serverQ/log efault location of AS ] 0Og 1ile.

defaultTrace.trc The standard log & trace file for the J2EE engine.
/usr/sap/<SID>/]JC<instance Location of RTA DS log files.
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no.>/j2ee/cluster/apps/sap.com/

xPlatform/servlet_jsp/xPlatformA

dapter/root/logs

xapp_error.log Contains the exceptions and various errors
occurred if any during the flow of execution of
the programs.

Xapp_info.log Contains the information about the flow of
execution of the programs

xapp_debug.log Contains additional information about the flow
of execution and error details for
troubleshooting/debug purposes.

13.1 CHANGING LOG LEVEL

Initially during the deployment process, the DEBUG level should be ON.
Therefore, it might incur large amount of logs in the RTA DS_LOGS folder on the
NetWeaver Java Stack server, where the application is deployed.

It is advised to monitor the size of the folder regularly for the spaced occupied. It
should be cleared and archived manually on a different server or drive if the logs
need to be gathered for some debugging purpose else the can be purged. Once
the initial testing for APIs is done and the process is stable then the logging level
can be changed. For more information on changing the log level, refer AVM-
RTA_Design_Studio_Installation_Configuration_Guide_v2.0SP05- section 8.3
Changing Log Level.
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14 APPENDIX

This chapter provides information about the AVM-RTADS repository.

141 AVM-RTADS REPOSITORY

14.2

1.

Real Time Analysis consumes lot of time as data is in huge amount. For this
purpose, the AVM-RTA DS application introduces a new functionality as, "
AVM-RTADS Repository".

In case of the Real Time analysis, when a request comes in from GRC, a call

to the target ERP is made and a user or role information is fetched from the

target ERP system on the real time basis. However, this is a time consuming
process.

In case of the AVM-RTADS Repository, the RTA DS application fetches data
for users, roles in the database instead of making the direct call to the target
ERP system. It saves time as it happens during real time and improves
performance utilization.

When the AVM-RTADS Repository is enabled, the offline analysis jobs
should be scheduled and completed before risk analysis is initiated in GRC to
ensure that latest data is fetched and stored in RTA DS.

You can configure the AVM-RTADS Repository checking under the
Configuration> Application Center> Systems- Create. On the Systems>
Create page, check the AVM-RTADS Repository flag. Once this flag is
checked, the RTA DS application fetches data cached for users, roles in the
database instead of making the call to the target ERP system.

AVM-RTADS REPOSITORY WORKFLOW

The sequential steps for the Offline Analysis are as follows.

1.

3.
4.

Create a System with RTADS Repository flag checked. Create a system with
the offline flag under the Configuration tab >Application Center>Systems-
Create. For more details on this, refer section, 5.2.2 Create a System.

Note: for the Offline Analysis, it is mandatory to create a system with AVM-
RTADS Repository flag.

Schedule jobs for the system for the six APIs (USERSYNC, USERACTION,
USERPERMISSION, ROLESYNC, ROLEACTION, ROLEPERMISSION).
Schedule a job under the Adapter Manager tab>Auto Batch Extraction> Job
Scheduler. For more details on this, refer section, 11.1.2 Job Scheduler Create.

Let the job complete.
Run the RISK ANALYSIS in the SAPGRC.
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14.3 SETTING ACCESS REQUEST PRIORITY VALUE

This section describes the steps to change the access request priority value within
AVM-RTA DS. An appropriate value for the access request priority needs to be
set within the AVM-RTA DS property file to ensure zero-stage GRC workflow is
utilized for the role removal API. The role removal API is invoked through ResQ
during template assignment termination process or template activation
termination process. For more information on this, refer:
GRC_CG_for_10.0_10.1_v1.5.pdf - section 4.7 Access Request Priority Value in
GRC.

14.3.1 AVM-RTA DS APPLICATION PROPERTIES FILE

1. Go to the path where AVM-RTA DS build is deployed, for example:
/usr/sap/GLS/]J07/j2ee/cluster/apps/sap.com/xPlatform/servlet_jsp/x
PlatformAdapter/root/ WEB-INF/ classes/rtads_application.properties

2. Open the text file rtads_application.properties.

3. Set appropriate value identified through the steps from section Access
Request Priority Value in GRC for the property
grc.user.access.request.priority e.g. grc.user.access.request.priority=006

4. Refer below screenshot with highlighted text.

|| rtads_application.properties o
1#JDBC Fetch Size
ZJjdbc.fetch.3ize= 50

4#Connection pool zize.
EHAX_POOLSIZE = 40

TLOGO _PATH = images!avm_lagu.pnq

SLOGO ALLOWED = Yes
10
llgro.user,access. request, priority=006

lZgro.user.,access.change. user..action,. 1d=001
ligro.user.,access.remove.role.action, id=009
l4gro.user.,.access.prov. line, item. system=373
l5gro.user,access.prov. line,.item.role=R0OL
legre.user,access, prov. line. item.approval _status.approved=AaP
17groc.user,access.prov. line.item.role.type.single=3IN
l8groc.user,access.flag.request,. initiated. from.gl.app=GLAFF
l19grec.user . access.custom. field.reason.code=Zi5STOREREGICH
20gro.user,access.prov. line, item.dtformat=yyyyNHdd

ZZ3ys.param.grc, USeraccess. ws, conn=GRCACCEIINS

Z3gys.param.yrc.requestdetails.ws. conn=GRCRO3ITDTL3WS
Z4gya.param.gro,. gero.stg. workflow. request=ZERONFREQUESTID

Figure 14.1: rtads_application.properties
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5. Restart AVM-RTA DS application after changing the value in the property
file.
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15 TROUBLESHOOTING

The list of the troubleshooting scenarios with regards to Installation of AVM-RTA
DS with the solution is as follows:
1. Not able to login to AVM-RTA DS application.
Solution:
To be able to login to the AVM-RTA DS application,

a.
b.

First make sure the platform has been properly registered.

Go to Platform Registration on the applications Home Page and check
whether the status is REGISTERED.

Second, make sure the User Id you are trying to enter into the system has the
appropriate RTA roles to login through SAP UME.

Ensure the UME password is correct and if necessary have the Administrator
reset the password.

2. Why I am not getting risks in CC/RAR?
Solution:

For this problem there could be any of the following possibilities:

a.

b.

C.

Please make sure that System name in CC/RAR is same as External Id of the
corresponding System in RTA.

Please check whether System in RTA Design Studio is registered.
Please make sure that system is mapped to your Adapter APlIs.

3. Why the connector types are not showing when the master data is imported?

Solution:

a. Make sure that the installation scripts were run during the installation of the
RTA DS.

b. If not run then, run the delete scripts once on the Database schema where
RTA DS application is installed to delete the data that might have already
been created.

c. Run the installation scripts and then try re - importing the Master data.

4. Not able to find pre-configured roles to be attached to AVM-RTA DS
application users.

Solution:

a.
b.

To be able to associate roles to the AVM-RTA DS application user;

Make sure you have imported the pre-configured role file into Sap UME
through NetWeaver administrator.
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5. The RTA cannot connect to the target ERP database because the database
crashed or was offline. How do I reconnect it?

Solution:

a. Ensure that all the services are restarted in SAP Management Console. If this
does not help then the server needs to be restarted.

b. This will clear all the inconsistencies. Once the server is started bring up all
the services in SAP Management Console.

6. Why Standard Adapter mapping is not available?
Solution:

a. Once you overwrite the Master data or Standard Adapter then all the
previously done mappings for Standard adapters will be removed. So you
need to go and do system-adapter mapping again.

7. Why Auto Job execution is failing?
Solution:

a. If ajob is scheduled and it does not have any data then that job will fail. This
is a known issue that is scheduled to be delivered in the next release.

b. Check whether system is mapped to the correct APL

8. Why Program is failing in Test Program?
Solution:

a. Please check connection for connector.
b. Please check whether the adapter program is correct.

While performing test program please provide values for all input
parameters. If you perform test program without providing values, then the
program will fail.

d. If it is a JDBC connector and if the database onto which the connector has
been restarted then the RTA DS application needs to be restarted to make a
fresh connection to the database by the JDBC connector. Restart the RTA DS
application and try the test connection again.

9. Why am I not able to associate the already attached system to the API once I
overwrite the Adapter?

Solution:

a. This is a known issue in the current release. Anytime you need to overwrite
the already existing adapter; you need to import the Master xml with the
overwrite check box checked.

b. First import the master data in overwrite mode.

Re import, the adapter and now you can attach the system to the APL
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10. Why am I not able to see the updated log entries even though I made a change
to a connector in AVM-RTA DS?

Solution:

a. If you open a log file such as the Error Log, Debug Log or the Info Log in the
application and do not see the current time stamped entries, your internet
browser may not be displaying the latest data. Clear your temporary internet

files and reopen the log file. This issue should now be fixed in the current
software release.
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16 TERMS AND DEFINITIONS

API API stands for “ Application Programming Interface”. An
APl is the definition of how a programmer can access the
functionality contained within a code library.

Application The application is a homogeneous group of systems.

Application Registration

The process of registering the applications created in RTA
DS with a valid key provided by Greenlight Technologies.

Auto Batch Extract Auto Batch Extract delivers the data required by SAP RAR
in the Flat File Format. Batch extracts generate tab
delimited flat files which enable to perform the offline risk
analysis for a system.

AVM Access Violation Management

Connection Type

Connection Type refers to the connection mechanism
implemented to get the data from the system onto which
this connector is attached. E.g. JDBC.

Custom Adapters

Adapters created by the customer in-house or delivered
by System Integration Partners of Greenlight Technologies
without the use of Import Adapter utility.

Customer ID

The ID provided by Greenlight Technologies to the
Customer when the request for Platform registration is
received by Greenlight Technologies.

Data source Type

The data source type stands for the type of database that is
referred to in pulling information for the particular
system. It can be relational, file based systems(C/D-ISAM)
or LDAP systems.

External System Id

External System Id is the system name as defined in the
SAP RAR.

FTP

File Transfer Protocol (FTP), a standard Internet protocol,
is the simplest way to exchange files between computers
on the Internet.

Informer

Informer tab of RTA DS consists of the customized reports
that can be run through RTA DS.

JDBC

Java Database Connectivity (JDBC) is an application
program interface (API) specification for connecting
programs written in Java to the data in popular databases.
The application program interface lets you encode access
request statements in Structured Query Language (SQL)
that are then passed to the program that manages the
database. It returns the results through a similar interface.

Logs

The error and debug logs created by the RTA DS
application.

Greenlight Technologies, Inc.

Page 122 of 123




Geentignt

AVM- RTA Design Studio User Guide v2.0SP07

Master Data Master Data refers to the configuration data imported into
RTA DS in the form of xml that defines the connector
types and the SAP and GRC APIs, various constraints and

mapping between the two.

NWA Net Weaver Administrator

Platform Registration The process of registering the RTA DS platform with a
valid key provided by Greenlight Technologies.

RAR Risk Analysis and Remediation (alternatively known as
Compliance Calibrator)

RTA DS Real Time Analysis Design Studio abbreviated as RTA DS

is the Java based application that extends and leverages
SAP GRC capabilities to non-SAP systems.

SAP UME SAP User Management Engine (UME). The data
repositories or persistence layers from which SAP User
Management Engine (UME) retrieves user management
data are referred to as data sources. With UME you can
leverage existing user data repositories in your system
infrastructure by connecting to them using configurable
persistence adapters. You can read data from and write
data to multiple data sources in parallel. For example, you
can configure UME so that user data is read from an
existing corporate directory, while new users are written
to a database. A persistence manager is responsible for
reading the data from or writing the data to the correct
data source. The data source to which the persistence
manager writes is transparent to applications using UME.

SMTP SMTP (Simple Mail Transfer Protocol) is a TCP/IP
protocol used in sending and receiving e-mail.

Standard Adapters Adapters delivered by Greenlight Technologies, by
importing the xml through the Import Adapter utility of
RTA DS.

System Registration The process of registering the systems created in RTA DS
with a valid key provided by Greenlight Technologies.

XML XML (Extensible Markup Language) is a flexible way to

create common information formats and share both the
format and the data on the World Wide Web, intranets,
and elsewhere. For example, computer makers might
agree on a standard or common way to describe the
information about a computer product (processor speed,
memory size, and so forth) and then describe the product
information format with XML.
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